aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-30 20:37:37 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-05-01 02:42:31 +0000
commit56876720920cec5a3d0df4b88248199a98d3e00c (patch)
treec4bd6635bde25fd5877e51564e34c0c66022abbf /main
parent1b986b07d7ef1eb6f9f682eea230c7cf04eb632e (diff)
downloadaports-56876720920cec5a3d0df4b88248199a98d3e00c.tar.bz2
aports-56876720920cec5a3d0df4b88248199a98d3e00c.tar.xz
main/aconf: add missing dependency on lua-filesystem
Diffstat (limited to 'main')
-rw-r--r--main/aconf/APKBUILD11
1 files changed, 2 insertions, 9 deletions
diff --git a/main/aconf/APKBUILD b/main/aconf/APKBUILD
index 3c391c0fb8..c4128bf89e 100644
--- a/main/aconf/APKBUILD
+++ b/main/aconf/APKBUILD
@@ -10,17 +10,16 @@ license="BSD"
_luaver="5.3"
_lua="lua$_luaver"
depends="$_lua-augeas $_lua-b64 $_lua-cjson $_lua-file-magic $_lua-openrc
- $_lua-ossl $_lua-posix $_lua-stringy uwsgi uwsgi-lua"
+ $_lua-ossl $_lua-posix $_lua-stringy $_lua-filesystem uwsgi uwsgi-lua"
makedepends="ldoc"
source="https://dev.alpinelinux.org/archive/aconf/aconf-$pkgver.tar.xz
$pkgname.initd"
-builddir="$srcdir/$pkgname-$pkgver"
options="!check"
_modules="dnsmasq dns-zone network openssh strongswan"
_escape() {
- echo ${1//-/_}
+ echo ${1//-/_}
}
subpackages="$pkgname-doc $pkgname-openrc"
@@ -33,12 +32,6 @@ done
_deps_dns_zone=
_deps_network=
-
-
-build() {
- :
-}
-
package() {
make LUA_VERSION=$_luaver ROOT_DIR=$pkgdir install
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname