aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-23 06:26:29 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-12 15:20:48 +0000
commit57eabb486f30b5697cab13e79e2782e14e7731ab (patch)
tree0c916c6efd4d042e9faa765014f05da14e53662c /main
parentf63d62ff797aad1963bebb9372a1eece586b8b80 (diff)
downloadaports-57eabb486f30b5697cab13e79e2782e14e7731ab.tar.bz2
aports-57eabb486f30b5697cab13e79e2782e14e7731ab.tar.xz
main/openpgm: switch to python3
Diffstat (limited to 'main')
-rw-r--r--main/openpgm/APKBUILD43
-rw-r--r--main/openpgm/python3.patch28
2 files changed, 45 insertions, 26 deletions
diff --git a/main/openpgm/APKBUILD b/main/openpgm/APKBUILD
index a8407093d9..4664e3962c 100644
--- a/main/openpgm/APKBUILD
+++ b/main/openpgm/APKBUILD
@@ -2,33 +2,27 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=openpgm
pkgver=5.2.122
-pkgrel=1
+pkgrel=2
pkgdesc="An implementation of the PGM reliable multicast protocol"
url="https://code.google.com/archive/p/openpgm/"
arch="all"
-license="LGPL-2.1"
-depends=""
-depends_dev=""
-makedepends="$depends_dev python2 perl"
-install=""
+license="LGPL-2.1-or-later"
+makedepends="python3 perl"
subpackages="$pkgname-dev"
source="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/openpgm/libpgm-$pkgver.tar.bz2
- openpgm-fix-includes.patch"
+ openpgm-fix-includes.patch
+ python3.patch
+ "
-_builddir="$srcdir"/libpgm-$pkgver/openpgm/pgm/
+builddir="$srcdir"/libpgm-$pkgver/openpgm/pgm/
prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- update_config_sub || return 1
+ cd "$builddir"
+ default_prepare
+ update_config_sub
}
build() {
- cd "$_builddir"
+ cd "$builddir"
CFLAGS="$CFLAGS -D_GNU_SOURCE" \
./configure \
--build=$CBUILD \
@@ -36,18 +30,15 @@ build() {
--prefix=/usr \
--enable-shared \
--disable-static \
- || return 1
- make || return 1
+ PYTHON=python3
+ make
}
package() {
- cd "$_builddir"
- make install DESTDIR="$pkgdir" || return 1
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
}
-md5sums="06d6e16bc9064379caf0f8fe979dc785 libpgm-5.2.122.tar.bz2
-11816d65ee6afc71d795d9ddbc0552d1 openpgm-fix-includes.patch"
-sha256sums="2f6fcdad7fcf08368bce100db2598abdd57cb1e55869df68c0032a12ffe86d93 libpgm-5.2.122.tar.bz2
-7030405c450251953841866a08641ac329384eacbc036f4954f5f6461f71887d openpgm-fix-includes.patch"
sha512sums="dddd5c30f7ae9a6a2ca9738010d4e6a1b856f3d7e1636bb43ef697a0b07ad6f058978d6f21cc3f6efe0c21b48d71d496d1e914bd05e33ed6cfbda8b96821fa2f libpgm-5.2.122.tar.bz2
-6689ccafa00a9d436fb6074b6454df4443daa2e62db47c64a962dfb105ce2d0f85c79059aa27ac9834572cd30112e7f0407e24dfd995285fa7ac921d70214229 openpgm-fix-includes.patch"
+6689ccafa00a9d436fb6074b6454df4443daa2e62db47c64a962dfb105ce2d0f85c79059aa27ac9834572cd30112e7f0407e24dfd995285fa7ac921d70214229 openpgm-fix-includes.patch
+51378950af33062339b49019a9fe78a07ff60bda0ed08905cc6bd4a5a4b3ff2347e10a11c50355e7f03422325f2834e054db1e44afa5c3b02c54a7a9963a04b8 python3.patch"
diff --git a/main/openpgm/python3.patch b/main/openpgm/python3.patch
new file mode 100644
index 0000000000..f1ae79772c
--- /dev/null
+++ b/main/openpgm/python3.patch
@@ -0,0 +1,28 @@
+diff --git a/version_generator.py b/version_generator.py
+index b2f8f9a..0143d67 100755
+--- a/version_generator.py
++++ b/version_generator.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python3
+
+ import os
+ import platform
+@@ -8,7 +8,7 @@ build_date = time.strftime ("%Y-%m-%d")
+ build_time = time.strftime ("%H:%M:%S")
+ build_rev = filter (str.isdigit, "$Revision: 1487 $")
+
+-print """
++print("""
+ /* vim:ts=8:sts=8:sw=4:noai:noexpandtab
+ *
+ * OpenPGM version.
+@@ -50,6 +50,6 @@ const char* pgm_build_revision = "%s";
+
+
+ /* eof */
+-"""%(build_date, build_time, platform.system(), platform.machine(), build_rev)
++"""%(build_date, build_time, platform.system(), platform.machine(), build_rev))
+
+ # end of file
+