aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-13 06:52:14 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-13 11:26:48 +0000
commit65d7341d091149ee453bcca5673b8728d1b1459c (patch)
tree501e247cc461727913a012158494d6b5d28f711d /main
parent3406e2b02b3e747fcf7d9773c0ff9cbbf503b549 (diff)
downloadaports-65d7341d091149ee453bcca5673b8728d1b1459c.tar.bz2
aports-65d7341d091149ee453bcca5673b8728d1b1459c.tar.xz
main/pax-utils: add missing dependencies on py3-elftools and python3
Diffstat (limited to 'main')
-rw-r--r--main/pax-utils/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/main/pax-utils/APKBUILD b/main/pax-utils/APKBUILD
index 204e9c901a..72e78fa672 100644
--- a/main/pax-utils/APKBUILD
+++ b/main/pax-utils/APKBUILD
@@ -3,15 +3,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pax-utils
pkgver=1.2.5
-pkgrel=1
+pkgrel=2
pkgdesc="ELF related utils for ELF 32/64 binaries"
url="https://wiki.gentoo.org/wiki/Hardened/PaX_Utilities"
arch="all"
license="GPL-2.0-only"
-depends="scanelf"
+depends="scanelf python3 py3-elftools"
makedepends_host="linux-headers libcap-dev"
makedepends="$makedepends_host"
-checkdepends="bash python3 py3-elftools"
+checkdepends="bash"
source="https://dev.gentoo.org/~slyfox/distfiles/pax-utils-$pkgver.tar.xz"
subpackages="$pkgname-doc scanelf:_scanelf"
@@ -33,8 +33,8 @@ package() {
}
_scanelf() {
- pkgdesc="Scan ELF binaries for stuff"
depends=""
+ pkgdesc="Scan ELF binaries for stuff"
replaces="pax-utils"
mkdir -p "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/bin/scanelf "$subpkgdir"/usr/bin/