aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2019-04-04 06:28:46 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-04 06:33:54 +0000
commit6805dcf402b37c2c8545a236f68334922e26b804 (patch)
treece48eb0ca572989ca220764acede6e57d8685ba6 /main
parent6ac03cd169f19c102d0f8d66628f60efae5d6f91 (diff)
downloadaports-6805dcf402b37c2c8545a236f68334922e26b804.tar.bz2
aports-6805dcf402b37c2c8545a236f68334922e26b804.tar.xz
main/py3-simpleparse: use pyhton3
Update license, disable check()
Diffstat (limited to 'main')
-rw-r--r--main/py-simpleparse/APKBUILD41
-rw-r--r--main/py-simpleparse/py-simpleparse-eols.patch33
-rw-r--r--main/py3-simpleparse/APKBUILD26
3 files changed, 26 insertions, 74 deletions
diff --git a/main/py-simpleparse/APKBUILD b/main/py-simpleparse/APKBUILD
deleted file mode 100644
index 6eeabf050e..0000000000
--- a/main/py-simpleparse/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
-pkgname=py-simpleparse
-_pkgname=SimpleParse
-pkgver=2.2.0
-pkgrel=0
-pkgdesc="Python library providing simple and fast parser generator"
-url="https://launchpad.net/simpleparse"
-arch="all"
-license="BSD"
-depends="python2"
-depends_dev="python2-dev"
-makedepends="$depends_dev"
-install=
-subpackages=
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip
- py-simpleparse-eols.patch"
-
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
- return 0
-}
-
-build() {
- cd "$_builddir"
- python2 setup.py build
-}
-
-package() {
- cd "$_builddir"
- python2 setup.py install --skip-build --root="$pkgdir"
-}
-
-md5sums="e4c37a05be0ac33148b19be83a657fd8 SimpleParse-2.2.0.zip
-b980d7400e2d5a97769330c5c2d927b3 py-simpleparse-eols.patch"
-sha256sums="6be9516405c8c798fe9d2bf723a506b4bfe8c717bf8af26cc27b165469b5d357 SimpleParse-2.2.0.zip
-14a8deb2da177f2a0b3051f344e22e94d3df311c52b68ab5445be107ebda211f py-simpleparse-eols.patch"
-sha512sums="90956843384739b52a0dc5397633f089c519b4acf922ad953dba49686a4e2c243f8bff6586c1f54c84cdef0c9555fbf6681c41ca70a4bf0f716f2892ae913b0e SimpleParse-2.2.0.zip
-780a2b8cc2164f18da4c21fbb79c667446a8b151c6f6bf063edf47b7463f87d330817ba9e62213f55664fab62e6a63d4864dfab648a2a888fca618e317a38faa py-simpleparse-eols.patch"
diff --git a/main/py-simpleparse/py-simpleparse-eols.patch b/main/py-simpleparse/py-simpleparse-eols.patch
deleted file mode 100644
index 9fc1362243..0000000000
--- a/main/py-simpleparse/py-simpleparse-eols.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-=== modified file 'examples/__init__.py'
---- examples/__init__.py 2008-11-09 22:58:29 +0000
-+++ examples/__init__.py 2011-08-17 18:31:28 +0000
-@@ -4,4 +4,4 @@
- well as a demonstration of using "pre-built"
- parser nodes (particularly one based on the re
- module).
--'''
-\ No newline at end of file
-+'''
-
-=== modified file 'examples/simpleexample2_2.py'
---- examples/simpleexample2_2.py 2008-11-09 22:58:29 +0000
-+++ examples/simpleexample2_2.py 2011-08-17 20:06:58 +0000
-@@ -34,4 +34,4 @@
- for testData in testEquality:
- success, children, nextcharacter = parser.parse( testData, production=production)
- assert success and nextcharacter==len(testData), """Wasn't able to parse %s as a %s (%s chars parsed of %s), returned value was %s"""%( repr(testData), production, nextcharacter, len(testData), (success, children, nextcharacter))
--
-\ No newline at end of file
-+
-
-=== modified file 'examples/vrml.py'
---- examples/vrml.py 2008-11-09 22:58:29 +0000
-+++ examples/vrml.py 2011-08-17 20:07:12 +0000
-@@ -57,4 +57,4 @@
- success, tags, next = parser.parse( data)
- d = time.time()-t
- print "parsed %s characters of %s in %s seconds (%scps)"%( next, len(data), d, next/(d or 0.000000001) )
--
-\ No newline at end of file
-+
-
diff --git a/main/py3-simpleparse/APKBUILD b/main/py3-simpleparse/APKBUILD
new file mode 100644
index 0000000000..3e1181a353
--- /dev/null
+++ b/main/py3-simpleparse/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=py3-simpleparse
+_pkgname=SimpleParse
+pkgver=2.2.0
+pkgrel=0
+pkgdesc="Python library providing simple and fast parser generator"
+url="https://launchpad.net/simpleparse"
+arch="all"
+license="eGenix ISC"
+depends="python3"
+makedepends="python3-dev"
+options="!check" # no test suite
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="90956843384739b52a0dc5397633f089c519b4acf922ad953dba49686a4e2c243f8bff6586c1f54c84cdef0c9555fbf6681c41ca70a4bf0f716f2892ae913b0e SimpleParse-2.2.0.zip"