aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-04 09:16:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-06 05:19:24 +0000
commit6f7f439be7bd93f944cea3780a3d95bf748890ba (patch)
tree1e80314392c1ee437818475264672fc364b4d460 /main
parentbf3d87d1baac7e1fe780595ce0e8fa7dba87af2a (diff)
downloadaports-6f7f439be7bd93f944cea3780a3d95bf748890ba.tar.bz2
aports-6f7f439be7bd93f944cea3780a3d95bf748890ba.tar.xz
main/open-isns: rebuild against libressl-2.7
Diffstat (limited to 'main')
-rw-r--r--main/open-isns/APKBUILD4
-rw-r--r--main/open-isns/libressl.patch11
2 files changed, 1 insertions, 14 deletions
diff --git a/main/open-isns/APKBUILD b/main/open-isns/APKBUILD
index 1da72f2749..6175dd2182 100644
--- a/main/open-isns/APKBUILD
+++ b/main/open-isns/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=open-isns
pkgver=0.97
-pkgrel=2
+pkgrel=3
pkgdesc="iSNS server and client for Linux"
url="https://github.com/open-iscsi/open-isns"
arch="all"
@@ -10,7 +10,6 @@ makedepends="autoconf automake libressl-dev musl-dev"
options="!check"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lib"
source="$pkgname-$pkgver.tar.gz::https://github.com/open-iscsi/open-isns/archive/v$pkgver.tar.gz
- libressl.patch
musl-fixes.patch
"
builddir="$srcdir"/$pkgname-$pkgver
@@ -50,5 +49,4 @@ lib() {
}
sha512sums="78c934162d5a1d093bccd49449d4ef369b896d34309d76b4963d643a699640617c4fe064388c481c35b9be26e012f19713f3aad378af9ad88fa94c3d300e919d open-isns-0.97.tar.gz
-3a01a78c19114801ce4d80568eca158615f338a27133eb7639258ebb9114afa66cbbf0c0d871f00b7e85a4903f1c2444866daaccc3e3b187d0d4d47d7e86adc2 libressl.patch
14eb43b8659c4c917fb35f2e33bffb90c7288555c3feb1ba4afd502c3e509bb44d0ad91b6c4ef09c68cd30eb812df11440a1c28720ee9be8cf4af6c0d8d6dc8d musl-fixes.patch"
diff --git a/main/open-isns/libressl.patch b/main/open-isns/libressl.patch
deleted file mode 100644
index f2137997cc..0000000000
--- a/main/open-isns/libressl.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/pki.c.orig
-+++ b/pki.c
-@@ -30,7 +30,7 @@
- #endif
- /* OpenSSL 1.1 made a lot of structures opaque, so we need to
- * define the 1.1 wrappers in previous versions. */
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- #define EVP_PKEY_base_id(o) ((o)->type)
- #define EVP_PKEY_get0_DSA(o) ((o)->pkey.dsa)
- static EVP_MD_CTX *EVP_MD_CTX_new(void)