aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2020-04-30 13:19:32 -0600
committerAriadne Conill <ariadne@dereferenced.org>2020-04-30 13:20:08 -0600
commit76044e31395d2088147cbfcaaceddbad2ffd08c4 (patch)
tree177c473164bc69ee6b28176baa7b194424b58c90 /main
parentcd433714440bade8f4e08150b287256cb8f53b7e (diff)
downloadaports-76044e31395d2088147cbfcaaceddbad2ffd08c4.tar.bz2
aports-76044e31395d2088147cbfcaaceddbad2ffd08c4.tar.xz
main/sngtc_client: fix underlinking issue
Diffstat (limited to 'main')
-rw-r--r--main/sngtc_client/APKBUILD8
-rw-r--r--main/sngtc_client/bctoolbox-underlinking.patch18
2 files changed, 23 insertions, 3 deletions
diff --git a/main/sngtc_client/APKBUILD b/main/sngtc_client/APKBUILD
index 55a4055623..43fc4566f6 100644
--- a/main/sngtc_client/APKBUILD
+++ b/main/sngtc_client/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.3.9
pkgrel=0
pkgdesc="Sangoma Media Transcode client and lib"
url="https://wiki.sangoma.com/Transcoding-distributed-install"
-arch="" # Fails to link against 'bctbx_set_log_level_mask'
+arch="all"
license="LGPL"
options="!check" #no test suite
makedepends="ortp-dev linux-headers bctoolbox-dev"
@@ -18,7 +18,8 @@ depends_dev="$pkgname=$pkgver-r$pkgrel"
source="ftp://ftp.sangoma.com/linux/transcoding/sng-tc-linux-$pkgver.i686.tgz
sngtc_client-dynamic-ortp.patch
musl-fix-types.patch
- ortp.patch"
+ ortp.patch
+ bctoolbox-underlinking.patch"
builddir="$srcdir"/sng-tc-linux-$pkgver.i686
prepare() {
@@ -44,4 +45,5 @@ package() {
sha512sums="c0449499418260a2bc2aafe7ae864ec72865a38e5af621a438265c32ae348f6c954f5029b0f56abecfc31a1a1022f7a3fb8b301589f98f681009db56d43d1afc sng-tc-linux-1.3.9.i686.tgz
2b784c56d1482ad9069502c408138d0c0b0ea6b393902d45b09200a3a588e02138c21a1fbee4d5715711e578130c30c607cae59f7ee24b8ce5bccd5a9c2fce14 sngtc_client-dynamic-ortp.patch
008447bf7c8f690cc9ee5efd232dee1b4f3f35e94827a518f88a7c46b4741b6d1e8418c32f099c807e61d7ae815467aed3a3b0134114e75574397ae324540067 musl-fix-types.patch
-5d1dcf45834e192f9c14681aa9e7f5fc58ae08b283f25f0565ac6522f8af06bf71585e3dd7c92ae727c86fa7bfbe7a27bd7bfcafe4913ab005d857a1fef34a56 ortp.patch"
+5d1dcf45834e192f9c14681aa9e7f5fc58ae08b283f25f0565ac6522f8af06bf71585e3dd7c92ae727c86fa7bfbe7a27bd7bfcafe4913ab005d857a1fef34a56 ortp.patch
+be6cc8a349b2dede19223cef2d888fc6ab183d832d75d77dfbd8b029b31814f9391d9b6af08d81e9765231faef0cdc9a3c50e7f847401d6ccc740f2cedd2f39c bctoolbox-underlinking.patch"
diff --git a/main/sngtc_client/bctoolbox-underlinking.patch b/main/sngtc_client/bctoolbox-underlinking.patch
new file mode 100644
index 0000000000..6b28a99a58
--- /dev/null
+++ b/main/sngtc_client/bctoolbox-underlinking.patch
@@ -0,0 +1,18 @@
+Upstream: no
+Reason: Fix underlinking due to bctoolbox symbol usage.
+
+diff -urN sng-tc-linux-1.3.9.i686.orig/client/sngtc_client/Makefile sng-tc-linux-1.3.9.i686/client/sngtc_client/Makefile
+--- sng-tc-linux-1.3.9.i686.orig/client/sngtc_client/Makefile 2020-04-30 13:17:32.005717991 -0600
++++ sng-tc-linux-1.3.9.i686/client/sngtc_client/Makefile 2020-04-30 13:17:53.909139976 -0600
+@@ -7,9 +7,9 @@
+ NO_NODE = 0
+
+ ifeq ($(NO_NODE),0)
+-LIBS = -lsngtc_node -lrt -lortp -lpthread
++LIBS = -lsngtc_node -lrt -lortp -lpthread -lbctoolbox
+ else
+-LIBS = -lsng-tc -lrt -lortp -lpthread
++LIBS = -lsng-tc -lrt -lortp -lpthread -lbctoolbox
+ CFLAGS += -DSNGTC_LIB_BIND
+ endif
+