aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-03-28 18:47:56 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-03-29 21:39:46 +0200
commit76bbdb8a7f9586627e4e2a6a895ce789c4102c91 (patch)
tree2a6c022950a9e4e3fc21926b9c39d19be4193f6b /main
parent24ad816aae98679cb42ae219b94f030b8fff9e87 (diff)
downloadaports-76bbdb8a7f9586627e4e2a6a895ce789c4102c91.tar.bz2
aports-76bbdb8a7f9586627e4e2a6a895ce789c4102c91.tar.xz
main/pmacct: copy recursive directories
During the build script, there is a command that tries to copy all the files from inside a directory, which happens to have a sub-directory, thus failing the build. This patch just execute a recursive copy, copying the sub-directory, and not failing the build.
Diffstat (limited to 'main')
-rw-r--r--main/pmacct/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/pmacct/APKBUILD b/main/pmacct/APKBUILD
index c2218c18ca..548571ddcd 100644
--- a/main/pmacct/APKBUILD
+++ b/main/pmacct/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=pmacct
pkgver=1.5.2
-pkgrel=0
+pkgrel=1
pkgdesc="Measure, account, classify, aggregate and export IPv4 and IPv6 traffic"
url="http://www.pmacct.net/"
arch="all"
@@ -66,7 +66,7 @@ package() {
ln -s /etc/init.d/pmacctd "$pkgdir"/etc/init.d/uacctd &>/dev/null
mkdir -p $pkgdir/usr/share/doc/pmacct/examples
mkdir -p $pkgdir/usr/share/doc/pmacct/sql
- cp examples/* $pkgdir/usr/share/doc/pmacct/examples
+ cp -r examples/* $pkgdir/usr/share/doc/pmacct/examples
cp sql/README.* $pkgdir/usr/share/doc/pmacct
cp sql/* $pkgdir/usr/share/doc/pmacct/sql
}