aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-12-30 14:54:12 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-07 10:13:47 +0100
commit78d37d9942be8548da47259a8b0f5ea584ed1f16 (patch)
treec071a4c1c2581c76002b213923520dff8a2f90d1 /main
parent92116a4678aa9557f35ec994424bb86ce1e21626 (diff)
downloadaports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.bz2
aports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.xz
tree-wide: use --buildtype=debugoptimized for meson packages
As of now we're using the buildttype 'release', which produces optimized builds but without any usable debugging info, which makes debugging crashes impossible, even if a -dbg subpackage exists. As such we should build in the buildmode 'debugoptimized' to offer proper debug symbols.
Diffstat (limited to 'main')
-rw-r--r--main/at-spi2-atk/APKBUILD4
-rw-r--r--main/at-spi2-core/APKBUILD4
-rw-r--r--main/atk/APKBUILD6
-rw-r--r--main/dconf/APKBUILD4
-rw-r--r--main/fuse3/APKBUILD4
-rw-r--r--main/glib/APKBUILD4
-rw-r--r--main/gobject-introspection/APKBUILD4
-rw-r--r--main/gst-plugins-base/APKBUILD4
-rw-r--r--main/gstreamer/APKBUILD4
-rw-r--r--main/libvdpau/APKBUILD4
-rw-r--r--main/mesa/APKBUILD4
-rw-r--r--main/orc/APKBUILD4
-rw-r--r--main/py3-gobject3/APKBUILD4
-rw-r--r--main/spice-protocol/APKBUILD4
-rw-r--r--main/sshfs/APKBUILD4
-rw-r--r--main/vte3/APKBUILD4
-rw-r--r--main/xorgproto/APKBUILD4
17 files changed, 35 insertions, 35 deletions
diff --git a/main/at-spi2-atk/APKBUILD b/main/at-spi2-atk/APKBUILD
index 591f2f0c9d..082aadd7d6 100644
--- a/main/at-spi2-atk/APKBUILD
+++ b/main/at-spi2-atk/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=at-spi2-atk
pkgver=2.34.1
-pkgrel=0
+pkgrel=1
pkgdesc="A GTK+ module that bridges ATK to D-Bus at-spi"
url="https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/"
arch="all"
@@ -19,7 +19,7 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
- --buildtype=release \
+ --buildtype=debugoptimized \
. output
ninja -C output
}
diff --git a/main/at-spi2-core/APKBUILD b/main/at-spi2-core/APKBUILD
index 9824efdaa2..f0cb16dcc7 100644
--- a/main/at-spi2-core/APKBUILD
+++ b/main/at-spi2-core/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=at-spi2-core
pkgver=2.34.0
-pkgrel=0
+pkgrel=1
pkgdesc="Protocol definitions and daemon for D-Bus at-spi"
url="https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/"
arch="all"
@@ -15,7 +15,7 @@ source="https://download.gnome.org/sources/at-spi2-core/${pkgver%.*}/at-spi2-cor
build() {
cd "$builddir"
meson \
- --buildtype=release \
+ --buildtype=debugoptimized \
--prefix=/usr \
-Dx11=yes \
-Dintrospection=yes \
diff --git a/main/atk/APKBUILD b/main/atk/APKBUILD
index 6c7851083c..4e8d0b7309 100644
--- a/main/atk/APKBUILD
+++ b/main/atk/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=atk
pkgver=2.34.1
-pkgrel=0
+pkgrel=1
pkgdesc="A library providing a set of interfaces for accessibility"
url="https://www.gtk.org/"
arch="all"
@@ -15,9 +15,9 @@ build() {
cd "$builddir"
meson \
--prefix=/usr \
- --buildtype=release \
+ --buildtype=debugoptimized \
--sysconfdir=/etc \
- --buildtype=release \
+ --buildtype=debugoptimized \
-Ddocs=true \
output .
ninja -C output
diff --git a/main/dconf/APKBUILD b/main/dconf/APKBUILD
index b42e830632..3dd439a8b2 100644
--- a/main/dconf/APKBUILD
+++ b/main/dconf/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=dconf
pkgver=0.34.0
-pkgrel=1
+pkgrel=2
pkgdesc="A low-level configuration system."
url="https://wiki.gnome.org/Projects/dconf"
arch="all"
@@ -18,7 +18,7 @@ build() {
meson \
--prefix=/usr \
--localstatedir=/var \
- --buildtype=release \
+ --buildtype=debugoptimized \
. output
ninja -C output
}
diff --git a/main/fuse3/APKBUILD b/main/fuse3/APKBUILD
index 408af81ccf..810bd439b5 100644
--- a/main/fuse3/APKBUILD
+++ b/main/fuse3/APKBUILD
@@ -2,7 +2,7 @@
pkgname=fuse3
_pkgname=fuse
pkgver=3.9.0
-pkgrel=0
+pkgrel=1
pkgdesc="The reference implementation of the Linux FUSE (Filesystem in Userspace) interface"
url="https://github.com/libfuse/libfuse"
arch="all"
@@ -30,7 +30,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --buildtype=release \
+ --buildtype=debugoptimized \
. output
ninja -C output
}
diff --git a/main/glib/APKBUILD b/main/glib/APKBUILD
index e19dea19d1..fac0946ddf 100644
--- a/main/glib/APKBUILD
+++ b/main/glib/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=glib
pkgver=2.62.4
-pkgrel=0
+pkgrel=1
pkgdesc="Common C routines used by Gtk+ and other libs"
url="https://developer.gnome.org/glib/"
arch="all"
@@ -33,7 +33,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --buildtype=release \
+ --buildtype=debugoptimized \
-Dman=true \
. output
ninja -C output
diff --git a/main/gobject-introspection/APKBUILD b/main/gobject-introspection/APKBUILD
index 580485fe71..67f3d076b5 100644
--- a/main/gobject-introspection/APKBUILD
+++ b/main/gobject-introspection/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gobject-introspection
pkgver=1.62.0
-pkgrel=1
+pkgrel=2
pkgdesc="Introspection system for GObject-based libraries"
url="https://wiki.gnome.org/action/show/Projects/GObjectIntrospection"
arch="all"
@@ -21,7 +21,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --buildtype=release \
+ --buildtype=debugoptimized \
. output
ninja -C output
}
diff --git a/main/gst-plugins-base/APKBUILD b/main/gst-plugins-base/APKBUILD
index c865b53fa3..93d51f3c77 100644
--- a/main/gst-plugins-base/APKBUILD
+++ b/main/gst-plugins-base/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gst-plugins-base
pkgver=1.16.2
-pkgrel=0
+pkgrel=1
pkgdesc="GStreamer streaming media framework base plug-ins"
url="https://gstreamer.freedesktop.org"
arch="all"
@@ -25,7 +25,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --buildtype=release \
+ --buildtype=debugoptimized \
-Dalsa=enabled \
-Dintrospection=enabled \
-Dpackage-origin="https://alpinelinux.org" \
diff --git a/main/gstreamer/APKBUILD b/main/gstreamer/APKBUILD
index 9eff60c762..52f5f5af19 100644
--- a/main/gstreamer/APKBUILD
+++ b/main/gstreamer/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gstreamer
pkgver=1.16.2
-pkgrel=0
+pkgrel=1
pkgdesc="GStreamer streaming media framework"
url="https://gstreamer.freedesktop.org"
arch="all"
@@ -19,7 +19,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --buildtype=release \
+ --buildtype=debugoptimized \
-Dintrospection=enabled \
-Dbash-completion=disabled \
-Dptp-helper-permissions=capabilities \
diff --git a/main/libvdpau/APKBUILD b/main/libvdpau/APKBUILD
index e91d040466..01089993f3 100644
--- a/main/libvdpau/APKBUILD
+++ b/main/libvdpau/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libvdpau
pkgver=1.3
-pkgrel=0
+pkgrel=1
pkgdesc="Hardware-accelerated video playback library"
url="https://gitlab.freedesktop.org/vdpau/libvdpau"
arch="all"
@@ -18,7 +18,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --buildtype=release \
+ --buildtype=debugoptimized \
-Ddri2=true \
. output
ninja -C output
diff --git a/main/mesa/APKBUILD b/main/mesa/APKBUILD
index 6fd29d1201..85a846083d 100644
--- a/main/mesa/APKBUILD
+++ b/main/mesa/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mesa
pkgver=19.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Mesa DRI OpenGL library"
url="https://www.mesa3d.org"
arch="all"
@@ -112,7 +112,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --buildtype=release \
+ --buildtype=debugoptimized \
-Ddri-drivers-path=$_dri_driverdir \
-Dgallium-drivers=$_gallium_drivers \
-Ddri-drivers=$_dri_drivers \
diff --git a/main/orc/APKBUILD b/main/orc/APKBUILD
index 011f6ab5ae..6e8254c9d2 100644
--- a/main/orc/APKBUILD
+++ b/main/orc/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=orc
pkgver=0.4.31
-pkgrel=0
+pkgrel=1
pkgdesc="The Oil Run-time Compiler"
url="https://gstreamer.freedesktop.org/modules/orc.html"
arch="all"
@@ -26,7 +26,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --buildtype=release \
+ --buildtype=debugoptimized \
-Dorc-test=disabled \
. output
ninja -C output
diff --git a/main/py3-gobject3/APKBUILD b/main/py3-gobject3/APKBUILD
index f26d2b5ba1..7bf63a5761 100644
--- a/main/py3-gobject3/APKBUILD
+++ b/main/py3-gobject3/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=py3-gobject3
pkgver=3.34.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python bindings for the GObject library"
url="https://wiki.gnome.org/Projects/PyGObject/"
arch="all"
@@ -25,7 +25,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --buildtype=release \
+ --buildtype=debugoptimized \
-Dpython=python3 \
. output
diff --git a/main/spice-protocol/APKBUILD b/main/spice-protocol/APKBUILD
index 3a677393f3..72d19137ce 100644
--- a/main/spice-protocol/APKBUILD
+++ b/main/spice-protocol/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=spice-protocol
pkgver=0.14.0
-pkgrel=0
+pkgrel=1
pkgdesc="Spice protocol header files"
url="http://www.spice-space.org/"
arch="noarch"
@@ -16,7 +16,7 @@ build() {
cd "$builddir"
meson build/ \
- --buildtype=release \
+ --buildtype=debugoptimized \
--prefix=/usr \
--datadir=lib
diff --git a/main/sshfs/APKBUILD b/main/sshfs/APKBUILD
index 6beed2d995..a898d038f1 100644
--- a/main/sshfs/APKBUILD
+++ b/main/sshfs/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sshfs
pkgver=3.7.0
-pkgrel=0
+pkgrel=1
pkgdesc="FUSE client based on the SSH File Transfer Protocol"
url="https://github.com/libfuse/sshfs"
arch="all"
@@ -18,7 +18,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --buildtype=release \
+ --buildtype=debugoptimized \
. output
ninja -C output
}
diff --git a/main/vte3/APKBUILD b/main/vte3/APKBUILD
index 49e01849ff..6697ce12bf 100644
--- a/main/vte3/APKBUILD
+++ b/main/vte3/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=vte3
pkgver=0.58.3
-pkgrel=0
+pkgrel=1
pkgdesc="Virtual Terminal Emulator library"
url="https://developer.gnome.org/vte/"
arch="all"
@@ -23,7 +23,7 @@ prepare() {
build() {
cd "$builddir/build"
meson \
- --buildtype=release \
+ --buildtype=debugoptimized \
-Ddocs=false \
--prefix=/usr \
--sysconfdir=/etc \
diff --git a/main/xorgproto/APKBUILD b/main/xorgproto/APKBUILD
index 52e9ad5270..29ee8763fc 100644
--- a/main/xorgproto/APKBUILD
+++ b/main/xorgproto/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: prspkt <prspkt@protonmail.com>
pkgname=xorgproto
pkgver=2019.2
-pkgrel=0
+pkgrel=1
pkgdesc="Combined X.Org X11 protocol headers"
url="https://www.x.org"
arch="noarch"
@@ -51,7 +51,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --buildtype=release \
+ --buildtype=debugoptimized \
--datadir=/usr/lib \
-Dlegacy=true \
. output