aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2020-01-06 16:35:31 +0100
committerJakub Jirutka <jakub@jirutka.cz>2020-01-06 16:35:52 +0100
commit7921433e150638ea82de3460792d337bdc6c285d (patch)
tree45082f6a81eeefad7c651a555841b79c8daaa670 /main
parent15c7895bc40dd6045b60c3f9b74b0182cf6a58fd (diff)
downloadaports-7921433e150638ea82de3460792d337bdc6c285d.tar.bz2
aports-7921433e150638ea82de3460792d337bdc6c285d.tar.xz
main/nftables: add checkconfig to extra_commands
Diffstat (limited to 'main')
-rw-r--r--main/nftables/APKBUILD4
-rw-r--r--main/nftables/nftables.initd3
2 files changed, 4 insertions, 3 deletions
diff --git a/main/nftables/APKBUILD b/main/nftables/APKBUILD
index 00cdda23aa..6041f3b3e1 100644
--- a/main/nftables/APKBUILD
+++ b/main/nftables/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=nftables
pkgver=0.9.3
-pkgrel=4
+pkgrel=5
pkgdesc="Netfilter tables userspace tools"
url="https://netfilter.org/projects/nftables"
arch="all"
@@ -57,5 +57,5 @@ package() {
sha512sums="d264f6fc75c95510e29fe7d5b82ae418d502f40437b098ba6117ffb1374d9989d70a7296e2e58c5fb25142145a987bb9c160902637899f892589809f9541db43 nftables-0.9.3.tar.bz2
cca875473bbd7b2326afcaeec84b1f9826afb70fc67381a64f3ad104a13a314bd2c352e0fac1f602b9980edb2818bf6242373aa1634ce17bcc1d82eeb8b05b39 nftables.confd
-4430d732bf8aa468e9a2799c9cf6533f1833a8ae1f4e527d3c6e907055e5b603cfda0a6f34fdee914aa6605bb265736dc233dec3963d07112439d75f1301dc8c nftables.initd
+739e704b263b7afd124c5f497fef43c6f5de69f0a75e0a370c2b84f84619ca6a8a64fe704413c2d1cc1e4a0db062cce2c7fb807c202f9a1a1f60152bd45ad914 nftables.initd
059e0920517ff9f9c564bdfda6a06e8392a2755c01f8d0331a8577fd027713948d3f1e2cbe9da5077870181dc9e425d8c69e4c82ea6ee261fced4ab61aff3ad4 nftables.nft"
diff --git a/main/nftables/nftables.initd b/main/nftables/nftables.initd
index cdaa0d7640..3224ea1d01 100644
--- a/main/nftables/nftables.initd
+++ b/main/nftables/nftables.initd
@@ -3,10 +3,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-extra_commands="list panic save"
+extra_commands="checkconfig list panic save"
extra_started_commands="reload"
description="Manage nftable based firewall."
+description_checkconfig="Check validity of rulesets on disk without applying changes."
description_save="Save current nftables rulesets to disk."
description_list="Displays the current nftables ruleset."
description_panic="Immediately drop all packets on all interfaces."