aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-08 15:36:20 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-08 19:23:24 +0000
commit86347fb76ea35d4465b5198c100d095e42142eab (patch)
treee47d03841b983704cd06dd8ee25ca010d0e89b17 /main
parent6f56b82cbb3d74747286de59ba96e6a2e36bbebf (diff)
downloadaports-86347fb76ea35d4465b5198c100d095e42142eab.tar.bz2
aports-86347fb76ea35d4465b5198c100d095e42142eab.tar.xz
community/dvgrab: move from main
Diffstat (limited to 'main')
-rw-r--r--main/dvgrab/APKBUILD42
-rw-r--r--main/dvgrab/fix-narrowing.patch27
-rw-r--r--main/dvgrab/musl-fixes.patch24
3 files changed, 0 insertions, 93 deletions
diff --git a/main/dvgrab/APKBUILD b/main/dvgrab/APKBUILD
deleted file mode 100644
index f8af684dd8..0000000000
--- a/main/dvgrab/APKBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=dvgrab
-pkgver=3.5
-pkgrel=3
-pkgdesc="Utility to capture video from a DV camera"
-url="http://www.kinodv.org/"
-arch="all"
-license="GPL-2.0-or-later"
-depends=
-makedepends="libraw1394-dev libavc1394-dev libdv-dev libiec61883-dev
- libjpeg-turbo-dev"
-install=""
-subpackages="$pkgname-doc"
-source="https://prdownloads.sourceforge.net/kino/dvgrab-$pkgver.tar.gz
- musl-fixes.patch
- fix-narrowing.patch
- "
-
-builddir="$srcdir"/dvgrab-$pkgver
-build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
-}
-
-sha512sums="7d9cae1661d27dbef1d0dcdf18966a0ab386d936803ff7d071a18e0303fca45631c9b27187a413adfa4391c395e5909e3b8dc5c543d529e7805550f1a3ee6735 dvgrab-3.5.tar.gz
-c69220fa133812063fc6e237a1c15215b7163845d8f9b0e0aba589a86b875f194d2a6899f44449c3e209415ea94d14a13eeff23014ddda0e8a496a6973a0e21b musl-fixes.patch
-9c54e630efcbf2992e785a837b24abc62d064e5538156f4d8a4b16edea1d55a7a2a70163564b3139f29c33c8887166fea0a253da0a4e6bb540142bf5054c551d fix-narrowing.patch"
diff --git a/main/dvgrab/fix-narrowing.patch b/main/dvgrab/fix-narrowing.patch
deleted file mode 100644
index 169f8a3c14..0000000000
--- a/main/dvgrab/fix-narrowing.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 8dd729f2cf4cc5b99ad2e3961419cf71d2dfb843 Mon Sep 17 00:00:00 2001
-From: Aaro Koskinen <aaro.koskinen@iki.fi>
-Date: Sun, 15 May 2016 22:44:23 +0300
-Subject: [PATCH] iec13818-1.h: fix build with GCC 6.1.0
-
-Fix the following build issue with GCC 6.1.0:
-
-iec13818-1.h:45:75: error: narrowing conversion of '255' from 'int' to 'char' inside { } [-Wnarrowing]
- static char bitmask[8] = { 0x01, 0x03, 0x07, 0x0f, 0x1f, 0x3f, 0x7f, 0xff };
- ^
----
- iec13818-1.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/iec13818-1.h b/iec13818-1.h
-index 56a4aa0..e964288 100644
---- a/iec13818-1.h
-+++ b/iec13818-1.h
-@@ -42,7 +42,7 @@
- #define BCD(c) ( ((((c) >> 4) & 0x0f) * 10) + ((c) & 0x0f) )
-
- #define TOBYTES( n ) ( ( n + 7 ) / 8 )
--static char bitmask[8] = { 0x01, 0x03, 0x07, 0x0f, 0x1f, 0x3f, 0x7f, 0xff };
-+static unsigned char bitmask[8] = { 0x01, 0x03, 0x07, 0x0f, 0x1f, 0x3f, 0x7f, 0xff };
- #define GETBITS( offset, len ) do { \
- unsigned long value = 0; \
- while ( len > 0 ) \
diff --git a/main/dvgrab/musl-fixes.patch b/main/dvgrab/musl-fixes.patch
deleted file mode 100644
index 795530836c..0000000000
--- a/main/dvgrab/musl-fixes.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- ./error.h.orig 2014-04-02 14:09:23.163839471 +0000
-+++ ./error.h 2014-04-02 14:14:07.630616871 +0000
-@@ -22,6 +22,10 @@
-
- #include <stdarg.h>
-
-+#if !defined(__ASSERT_FUNCTION)
-+#define __ASSERT_FUNCTION __func__
-+#endif
-+
- #ifdef __cplusplus
- extern "C"
- {
---- ./io.c.orig 2014-04-02 14:14:29.104210187 +0000
-+++ ./io.c 2014-04-02 14:14:59.264575341 +0000
-@@ -31,6 +31,8 @@
- #include <termios.h>
- #include <unistd.h>
-
-+#include <sys/time.h>
-+
- /* Application header files */
- #include "io.h"
-