aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-11-21 15:48:20 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-11-21 15:48:20 +0200
commit91c0f1ba1f8c2219ca84f398174575b3963fad41 (patch)
tree17a9b257a47fdb24ab4f3c0c5c2169be1b9db03b /main
parent2f25146ddc5aee6d98fac42d7a5b87796d0dc003 (diff)
downloadaports-91c0f1ba1f8c2219ca84f398174575b3963fad41.tar.bz2
aports-91c0f1ba1f8c2219ca84f398174575b3963fad41.tar.xz
main/omxplayer: fix build and modernize
Diffstat (limited to 'main')
-rw-r--r--main/omxplayer/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/main/omxplayer/APKBUILD b/main/omxplayer/APKBUILD
index ec9c2f8fbc..f17c89ef41 100644
--- a/main/omxplayer/APKBUILD
+++ b/main/omxplayer/APKBUILD
@@ -33,18 +33,18 @@ LDFLAGS:=-L/opt/vc/lib -Wl,-rpath,/opt/vc/lib
LIBS:=$(pkg-config --libs freetype2 dbus-1)
STRIP:=echo
EOF
- make omxplayer.bin omxplayer.1
+ make omxplayer.bin
}
package() {
cd "$builddir"
- make install DIST="$pkgdir" || return 1
+ make install DIST="$pkgdir"
rm -rf "$pkgdir"/usr/lib/omxplayer
install -m755 -D "$srcdir"/$pkgname.initd \
- "$pkgdir"/etc/init.d/$pkgname || return 1
+ "$pkgdir"/etc/init.d/$pkgname
install -m644 -D "$srcdir"/$pkgname.confd \
- "$pkgdir"/etc/conf.d/$pkgname || return 1
+ "$pkgdir"/etc/conf.d/$pkgname
}
sha512sums="75a19d29e037d87b17edfe631590ba8e9035dc3ee8114e0398531f7f5fbfbc2947044ec56290dbeff90bba3e8231590b70270e39fcb2e1a91ca698c69e9aa02c omxplayer-0.20161017.tar.gz