aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorPaul Bredbury <brebs@sent.com>2019-02-24 21:17:12 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-03-06 12:40:59 +0000
commit95bb0f4036ffbe11e57d545fafb81927ca6ba726 (patch)
treec61699a09a751dd75bb73daa81459ebcdc045b49 /main
parent6be7e449714ff6fcfe2a22220a51ccfe9a95db21 (diff)
downloadaports-95bb0f4036ffbe11e57d545fafb81927ca6ba726.tar.bz2
aports-95bb0f4036ffbe11e57d545fafb81927ca6ba726.tar.xz
main/at-spi2-atk: default to disabled
Most people are not going to need these running: /usr/libexec/at-spi-bus-launcher /usr/libexec/at-spi2-registryd --use-gnome-session ... and their runnning can cause problems, e.g.: https://bugs.alpinelinux.org/issues/9574 Fixes #9574
Diffstat (limited to 'main')
-rw-r--r--main/at-spi2-atk/APKBUILD10
-rw-r--r--main/at-spi2-atk/bridge-default-off.patch28
2 files changed, 34 insertions, 4 deletions
diff --git a/main/at-spi2-atk/APKBUILD b/main/at-spi2-atk/APKBUILD
index 35c1545cb1..fef019e378 100644
--- a/main/at-spi2-atk/APKBUILD
+++ b/main/at-spi2-atk/APKBUILD
@@ -2,9 +2,9 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=at-spi2-atk
pkgver=2.26.2
-pkgrel=0
+pkgrel=1
pkgdesc="A GTK+ module that bridges ATK to D-Bus at-spi"
-url="http://www.linuxfoundation.org/en/AT-SPI_on_D-Bus"
+url="https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/"
arch="all"
options="!check" # Requires dbus daemon running.
license="LGPL-2.0-or-later"
@@ -14,7 +14,8 @@ makedepends="$depends_dev glib-dev at-spi2-core-dev intltool"
checkdepends="libxml2-dev"
install=""
subpackages="$pkgname-dev"
-source="https://download.gnome.org/sources/at-spi2-atk/${pkgver%.*}/at-spi2-atk-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/at-spi2-atk/${pkgver%.*}/at-spi2-atk-$pkgver.tar.xz
+ bridge-default-off.patch"
builddir="$srcdir"/at-spi2-atk-$pkgver
build() {
@@ -40,4 +41,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="f938b8e2b999fcdfa13e9433bd13c39430bae2ceae0c664a24caccc6af522947bf73de02de3c359807f5370a85961193df2ba24b193b60b915c61828ea747bb2 at-spi2-atk-2.26.2.tar.xz"
+sha512sums="f938b8e2b999fcdfa13e9433bd13c39430bae2ceae0c664a24caccc6af522947bf73de02de3c359807f5370a85961193df2ba24b193b60b915c61828ea747bb2 at-spi2-atk-2.26.2.tar.xz
+592f167c6255b3c44b2fcbbe9c9f8ab0133455fd4a393c47e833fedeccc84dd1ce2f4d2507f01116f6560fe58928b379355e438b6813214de4762ef95f4eec41 bridge-default-off.patch"
diff --git a/main/at-spi2-atk/bridge-default-off.patch b/main/at-spi2-atk/bridge-default-off.patch
new file mode 100644
index 0000000000..f5fc4a9002
--- /dev/null
+++ b/main/at-spi2-atk/bridge-default-off.patch
@@ -0,0 +1,28 @@
+diff -Naur a/atk-adaptor/bridge.c b/atk-adaptor/bridge.c
+--- a/atk-adaptor/bridge.c 2018-09-03 22:29:05.000000000 +0100
++++ b/atk-adaptor/bridge.c 2019-02-24 20:10:53.941760839 +0000
+@@ -916,7 +916,7 @@
+ /*
+ * Checks the status of the environment variables
+ *
+- * At this moment it only checks NO_AT_BRIDGE
++ * At this moment it only checks AT_BRIDGE
+ *
+ * Returns TRUE if there isn't anything on the environment preventing
+ * you to load the bridge, FALSE otherwise
+@@ -926,12 +926,12 @@
+ {
+ const gchar *envvar;
+
+- envvar = g_getenv ("NO_AT_BRIDGE");
++ envvar = g_getenv ("AT_BRIDGE");
+
+ if (envvar && atoi (envvar) == 1)
+- return FALSE;
+- else
+ return TRUE;
++ else
++ return FALSE;
+ }
+
+ void