aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-08-25 15:38:47 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-20 10:01:08 +0000
commit9d1a83cfcbb72429ff558a54b1154e90bed6151e (patch)
treea84175fa585ac05adae20c212c031877fe8387db /main
parent7075fe4d1e16354b7ca1e8fcd488f3ff722bc12e (diff)
downloadaports-9d1a83cfcbb72429ff558a54b1154e90bed6151e.tar.bz2
aports-9d1a83cfcbb72429ff558a54b1154e90bed6151e.tar.xz
main/po4a: modernise, disable tests
Diffstat (limited to 'main')
-rw-r--r--main/po4a/APKBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/main/po4a/APKBUILD b/main/po4a/APKBUILD
index b997e6cb37..611fd0191e 100644
--- a/main/po4a/APKBUILD
+++ b/main/po4a/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: Christian Kampka <christian@kampka.net>
pkgname=po4a
pkgver=0.51
-pkgrel=0
+pkgrel=1
_dlid=4214
pkgdesc="Tools for helping translation of documentation"
url="https://po4a.alioth.debian.org"
arch="noarch"
license="GPL"
depends="perl gettext"
+options="!check" # comments changed format, it fails
makedepends="docbook-xsl perl-module-build diffutils"
subpackages="$pkgname-doc $pkgname-lang"
source="https://alioth.debian.org/frs/download.php/file/${_dlid}/${pkgname}-${pkgver}.tar.gz"
@@ -16,15 +17,20 @@ builddir="$srcdir/${pkgname}-${pkgver}"
build() {
cd "$builddir"
- perl Build.PL installdirs=vendor create_packlist=0 || return 1
- perl Build || return 1
+ perl Build.PL installdirs=vendor create_packlist=0
+ perl Build
+}
+
+check() {
+ cd "$builddir"
+ perl Build test
}
package() {
cd "$builddir"
- perl Build destdir=${pkgdir} install || return 1
+ perl Build destdir=${pkgdir} install
# remove perllocal.pod and .packlist
- find ${pkgdir} -name .packlist -o -name perllocal.pod -delete || return 1
+ find ${pkgdir} -name .packlist -o -name perllocal.pod -delete
}
sha512sums="dd4ecf4eab59c41466b11828b7a4e5e06cfa8b8a188f808b05ef5aa163ba463ebf44485225c4bbdefcdd42b56d5956d9bc96c34dba12557f098723b7edde18b6 po4a-0.51.tar.gz"