aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-10 13:22:24 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-10 13:24:58 +0100
commita774d7b533e0bbc50fdedeac7121a5a6c043a323 (patch)
treef9df714374d3c806c5fbb2bc26c1d02552b8fbca /main
parent76c8b58ff71561ae88f1efdfd502c1471763784d (diff)
downloadaports-a774d7b533e0bbc50fdedeac7121a5a6c043a323.tar.bz2
aports-a774d7b533e0bbc50fdedeac7121a5a6c043a323.tar.xz
main/freeswitch: partial fix for PostgreSQL 10
This is incomplete, autohells detection still fails.
Diffstat (limited to 'main')
-rw-r--r--main/freeswitch/APKBUILD2
-rw-r--r--main/freeswitch/fix-build-for-postgresql10.patch36
2 files changed, 38 insertions, 0 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 4faaa9c91b..f9d8e86ccc 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -66,6 +66,7 @@ source="http://files.freeswitch.org/freeswitch-releases/$pkgname-$pkgver.tar.xz
0002-FS-verto-bswap_64.patch
sofia-sip-libressl.patch
getlib.patch
+ fix-build-for-postgresql10.patch
modules.conf
freeswitch.confd
freeswitch.initd
@@ -218,6 +219,7 @@ db61d9a253105f7a1ef5f5c218b367a833f62a2e85e364e3971acc79f68037b0270c5b2f3e090964
5f93150e1acd632df98bc3bed5613fb1e45180ae4096dcfee5c060da213c8355339260eaf5758cd77c785f6d84cf0661650a872ec574b586ab19803d4f6955f8 0002-FS-verto-bswap_64.patch
5bb95dff04714bb94a8973a78cf46beb335e026e3b5e9bf6f6a5b60d94387dbe431a72c3bf37e553dc34a9773a3ea63e05b0b28d243a3ef97ad833c28c904f85 sofia-sip-libressl.patch
4ceb48f64d2bc26a02cc0846276506241bfd30c156422b0a1d608fd172c099feb5c121a763652e9a45046dcdd0ba0eb71eab240e0c6ce2ad63ff781719e135a4 getlib.patch
+4bc881fcbd1fe43f4b1550088705e98467d41a61ba1c6ba213aae0fe07b6b0b5e486a3f807c9cbea8ee112391f6bd2954ebb48f3d9102d46100fb63219ec829d fix-build-for-postgresql10.patch
6deecb303e765d44bdd970d5a7079c9dd9ce17d12056b68cd978a182a86b477b4a3c19d2f5a18f36199ca2e0594a3b84de521ab821e2f8c89f7449a3d7f21279 modules.conf
a585f6411185a26206137a1ad97a06fd6c73e80c5439e9be45eabfa70e7a83120169ba882971fcd328436c8e0242cbd664170b80754ea2846021689baf1f1595 freeswitch.confd
643d0a2e43f5d3bf3b99fcb6f6422302cb4b74a95eccf844eafb100b15aa9856b4ff41f112d6637255c2e9e2bec9fedc9a9215dfff214dfb83b52eae16b71dca freeswitch.initd"
diff --git a/main/freeswitch/fix-build-for-postgresql10.patch b/main/freeswitch/fix-build-for-postgresql10.patch
new file mode 100644
index 0000000000..6d23110491
--- /dev/null
+++ b/main/freeswitch/fix-build-for-postgresql10.patch
@@ -0,0 +1,36 @@
+From 9d96741f56b7f663fd1b0ad625b4b7042832ebca Mon Sep 17 00:00:00 2001
+From: Italo Rossi <italorossib@gmail.com>
+Date: Mon, 6 Nov 2017 10:35:36 -0300
+Subject: [PATCH] FS-10774 - [switch_pgsql] Fix build for PostgreSQL/libpq 10
+
+Upstream-Issue: https://freeswitch.org/jira/browse/FS-10774
+Patch-Source: https://freeswitch.org/stash/projects/FS/repos/freeswitch/commits/9d96741f56b7f663fd1b0ad625b4b7042832ebca
+---
+ src/switch_pgsql.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/switch_pgsql.c b/src/switch_pgsql.c
+index 7928624270..f3411361fd 100644
+--- a/src/switch_pgsql.c
++++ b/src/switch_pgsql.c
+@@ -386,7 +386,7 @@ SWITCH_DECLARE(switch_pgsql_status_t) switch_pgsql_next_result_timed(switch_pgsq
+ *result_out = res;
+ res->status = PQresultStatus(res->result);
+ switch(res->status) {
+-#if POSTGRESQL_MAJOR_VERSION >= 9 && POSTGRESQL_MINOR_VERSION >= 2
++#if (POSTGRESQL_MAJOR_VERSION == 9 && POSTGRESQL_MINOR_VERSION >= 2) || POSTGRESQL_MAJOR_VERSION > 9
+ case PGRES_SINGLE_TUPLE:
+ /* Added in PostgreSQL 9.2 */
+ #endif
+@@ -397,7 +397,7 @@ SWITCH_DECLARE(switch_pgsql_status_t) switch_pgsql_next_result_timed(switch_pgsq
+ res->cols = PQnfields(res->result);
+ }
+ break;
+-#if POSTGRESQL_MAJOR_VERSION >= 9 && POSTGRESQL_MINOR_VERSION >= 1
++#if (POSTGRESQL_MAJOR_VERSION == 9 && POSTGRESQL_MINOR_VERSION >= 1) || POSTGRESQL_MAJOR_VERSION > 9
+ case PGRES_COPY_BOTH:
+ /* Added in PostgreSQL 9.1 */
+ #endif
+--
+2.15.0
+