aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-25 17:40:48 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-08-26 09:31:08 +0000
commita8bbae0b2df1a938d18e8b54f8414f87f92d8285 (patch)
tree3218df4c464ff4c8f0ea6b2ad7ac866032d7d588 /main
parent3afb290aac518324e6cce69cc347cad435636ff4 (diff)
downloadaports-a8bbae0b2df1a938d18e8b54f8414f87f92d8285.tar.bz2
aports-a8bbae0b2df1a938d18e8b54f8414f87f92d8285.tar.xz
main/linux-pam: upgrade to 1.3.1
Diffstat (limited to 'main')
-rw-r--r--main/linux-pam/APKBUILD11
-rw-r--r--main/linux-pam/musl-fix-pam_exec.patch22
2 files changed, 19 insertions, 14 deletions
diff --git a/main/linux-pam/APKBUILD b/main/linux-pam/APKBUILD
index 48c752a2c9..6dbcee32fd 100644
--- a/main/linux-pam/APKBUILD
+++ b/main/linux-pam/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=linux-pam
-pkgver=1.3.0
-pkgrel=1
+pkgver=1.3.1
+pkgrel=0
pkgdesc="pluggable authentication modules for linux"
url="http://www.kernel.org/pub/linux/libs/pam"
arch="all"
@@ -10,7 +10,8 @@ depends_dev="gettext-dev"
makedepends="$depends_dev bison flex-dev autoconf automake libtool"
options="suid !check"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://linux-pam.org/library/Linux-PAM-$pkgver.tar.bz2
+source="
+ https://github.com/linux-pam/linux-pam/releases/download/v$pkgver/Linux-PAM-$pkgver.tar.xz
fix-compat.patch
libpam-fix-build-with-eglibc-2.16.patch
musl-fix-pam_exec.patch
@@ -72,10 +73,10 @@ package() {
&& chmod g+s "$pkgdir"/sbin/unix_chkpwd
}
-sha512sums="4a89ca4b6f4676107aca4018f7c11addf03495266b209cb11c913f8b5d191d9a1f72197715dcf2a69216b4036de88780bcbbb5a8652e386910d71ba1b6282e42 Linux-PAM-1.3.0.tar.bz2
+sha512sums="6bc8e2a5b64686f0a23846221c5228c88418ba485b17c53b3a12f91262b5bb73566d6b6a5daa1f63bbae54310aee918b987e44a72ce809b4e7c668f0fadfe08e Linux-PAM-1.3.1.tar.xz
52b97e23084f7b835ce1fa441663f91a50ea797cb38ba2c6662bcdaf0d25ba487118442674ac347fb17353af126dd6b3b696612faa56cac428dd842d14e1c90d fix-compat.patch
f49edf3876cc6bcb87bbea4e7beaeb0a382d596898c755f5fbaf6c2ed4e0c8f082b2cd16dde8a74af82bb09a1334f463e07a4bb5b8a48f023ff90a67ad2fdd44 libpam-fix-build-with-eglibc-2.16.patch
-bc443d2a9b1d90b81959ce6fa154042365d5e7840f8696f847a145bbaaeffcbe1e9cd2b8ba76131a7b48737929e281f4fe864582fa4fc40315f2d10c650e0cd9 musl-fix-pam_exec.patch
+08323428e13f65300d7638233fd8ab25c582a08ffe0a282ed43f69ccb428dea9eb185da3ae9dd2634f021c16592f194f99348758bd9e761c29435652b544f543 musl-fix-pam_exec.patch
bb368f3f05d5a2bacee2befeaa75adfb6fcf2aecf5d6e8e01842ec499920e62ff06bdc1ca91ce970b61d628c9036ca669bff38d4874d4a235071995aa1d82a56 base-auth.pamd
85462201a4044c7e170e617d39b0eceb4790abc6c0504999117548030a16d80a9d2078d1ad97690d7d346e6374201f0c52e792ccb08ce2b1c4bbf0cc2be96f5b base-account.pamd
8223b815148c3b9b874d2c283840f6428c266e56c7cf49ce8fc508c4945ae31c837bef96dab17f64a60812d1c9cd0055cf0a50d7951d23070b69bd2e5bb9666d base-password.pamd
diff --git a/main/linux-pam/musl-fix-pam_exec.patch b/main/linux-pam/musl-fix-pam_exec.patch
index b6b999faed..760660fa0c 100644
--- a/main/linux-pam/musl-fix-pam_exec.patch
+++ b/main/linux-pam/musl-fix-pam_exec.patch
@@ -1,6 +1,8 @@
---- ./modules/pam_exec/pam_exec.c.orig
-+++ ./modules/pam_exec/pam_exec.c
-@@ -103,11 +103,14 @@
+diff --git a/modules/pam_exec/pam_exec.c b/modules/pam_exec/pam_exec.c
+index 52dc681..4ed6e34 100644
+--- a/modules/pam_exec/pam_exec.c
++++ b/modules/pam_exec/pam_exec.c
+@@ -103,11 +103,14 @@ call_exec (const char *pam_type, pam_handle_t *pamh,
int optargc;
const char *logfile = NULL;
const char *authtok = NULL;
@@ -15,13 +17,14 @@
if (argc < 1) {
pam_syslog (pamh, LOG_ERR,
"This module needs at least one argument");
-@@ -178,11 +181,11 @@
+@@ -180,12 +183,12 @@ call_exec (const char *pam_type, pam_handle_t *pamh,
+ if (resp)
+ {
+ pam_set_item (pamh, PAM_AUTHTOK, resp);
+- authtok = strndupa (resp, PAM_MAX_RESP_SIZE);
++ authtok = strncpy(authtok_buf, resp, sizeof(authtok_buf));
+ _pam_drop (resp);
}
-
- pam_set_item (pamh, PAM_AUTHTOK, resp);
-- authtok = strndupa (resp, PAM_MAX_RESP_SIZE);
-+ authtok = strncpy(authtok_buf, resp, sizeof(authtok_buf));
- _pam_drop (resp);
}
else
- authtok = strndupa (void_pass, PAM_MAX_RESP_SIZE);
@@ -29,3 +32,4 @@
if (pipe(fds) != 0)
{
+