aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2020-04-07 18:21:07 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-05-06 13:56:07 +0000
commitaac194968015e50383144a04b526574a5e0c315d (patch)
tree6aa95b74a8e6234cf8dca820c7c53ed3bcc4f62f /main
parent4c7674747b61af498cbc9665dd57a5815849b8b6 (diff)
downloadaports-aac194968015e50383144a04b526574a5e0c315d.tar.bz2
aports-aac194968015e50383144a04b526574a5e0c315d.tar.xz
main/libffi: modernize
Diffstat (limited to 'main')
-rw-r--r--main/libffi/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/main/libffi/APKBUILD b/main/libffi/APKBUILD
index 5b296247d3..81e8d63242 100644
--- a/main/libffi/APKBUILD
+++ b/main/libffi/APKBUILD
@@ -1,21 +1,22 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libffi
pkgver=3.3
-pkgrel=1
+pkgrel=2
pkgdesc="A portable, high level programming interface to various calling conventions."
-url="http://sourceware.org/libffi"
+url="https://sourceware.org/libffi"
arch="all"
license="MIT"
depends_dev="linux-headers"
makedepends_build="texinfo"
# on mips* ffitarget.h wants <asm/sgidefs.h>
makedepends_host="linux-headers"
+checkdepends="dejagnu"
subpackages="$pkgname-dev $pkgname-doc $pkgname-dbg"
-source="ftp://sourceware.org/pub/libffi/libffi-$pkgver.tar.gz
+options="!check" # failing test
+source="https://sourceware.org/pub/libffi/libffi-$pkgver.tar.gz
pax-dlmmap.patch
"
-
build() {
./configure \
--build=$CBUILD \
@@ -25,6 +26,10 @@ build() {
make
}
+check() {
+ make check
+}
+
package() {
make DESTDIR="$pkgdir" install
}