aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-24 08:46:19 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-05 15:33:49 +0000
commitae97a6a1f1298cc4f08175a8900f9ff0122b70dc (patch)
tree6575a13ae57d1d2e2c06327d8efd0e8d4a48ed69 /main
parentb8779cb2cc01a68e57138f483852262c0acc4a55 (diff)
downloadaports-ae97a6a1f1298cc4f08175a8900f9ff0122b70dc.tar.bz2
aports-ae97a6a1f1298cc4f08175a8900f9ff0122b70dc.tar.xz
main/py3-filelock: drop python2
Diffstat (limited to 'main')
-rw-r--r--main/py3-filelock/APKBUILD37
1 files changed, 10 insertions, 27 deletions
diff --git a/main/py3-filelock/APKBUILD b/main/py3-filelock/APKBUILD
index 69b5506ba4..a51668bcd9 100644
--- a/main/py3-filelock/APKBUILD
+++ b/main/py3-filelock/APKBUILD
@@ -1,52 +1,35 @@
# Contributor: Dmitry Romanenko <dmitry@romanenko.in>
# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
-pkgname=py-filelock
+pkgname=py3-filelock
_pkgname=filelock
pkgver=3.0.12
-pkgrel=0
-pkgdesc="A platform independent file lock for Python"
+pkgrel=1
+pkgdesc="A platform independent file lock for Python3"
url="https://github.com/benediktschmitt/py-filelock"
arch="noarch"
license="Unlicense"
-depends=""
-checkdepends="pytest"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
+depends="python3"
+checkdepends="py3-pytest"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/f/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-filelock" # Backwards compatibility
+provides="py-filelock=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
check() {
cd "$builddir"
- python2 -m pytest -xvv test.py
python3 -m pytest -xvv test.py
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="09b8b16c12a60044a259a5d644bc8066660871104a7f4cd431431173d475b9f15744adfb8d86ec8cda69f2a1b52bd14cb8a066d70fa5e49c449bc5ee702ec2a0 filelock-3.0.12.tar.gz"