aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-10-19 10:59:18 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-10-19 10:59:18 +0200
commitb975705efe499167247d6b1bcd32d3825bbd89ac (patch)
treebf5faa39bf00b1f18cf6367cb4287ca2af36651f /main
parent0a68e55f536c0b9d044c0e4951b6819564ac6e13 (diff)
downloadaports-b975705efe499167247d6b1bcd32d3825bbd89ac.tar.bz2
aports-b975705efe499167247d6b1bcd32d3825bbd89ac.tar.xz
main/libmpdclient: set meson buildtype to release
Default is debug :(
Diffstat (limited to 'main')
-rw-r--r--main/libmpdclient/APKBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/main/libmpdclient/APKBUILD b/main/libmpdclient/APKBUILD
index a8a6532d85..bb64963b1f 100644
--- a/main/libmpdclient/APKBUILD
+++ b/main/libmpdclient/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libmpdclient
pkgver=2.13
-pkgrel=0
+pkgrel=1
pkgdesc="An asynchronous API library for interfacing MPD in the C, C++ & Objective C languages"
url="https://www.musicpd.org/libs/libmpdclient"
arch="all"
@@ -14,7 +14,13 @@ builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- meson --prefix=/usr . output
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
ninja -C output
}