aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorAndrew Gunnerson <andrew.gunnerson@us.ibm.com>2020-02-14 13:32:03 -0500
committerLeo <thinkabit.ukim@gmail.com>2020-02-14 16:59:59 -0300
commitd4cb60d815b65332d022275cb0eefa7fbf5ee94c (patch)
tree5d57998e7d974562c5fa8c74596394b0c477f677 /main
parent79011f7c7c507e116de86b64bc6e00b3fb1e651b (diff)
downloadaports-d4cb60d815b65332d022275cb0eefa7fbf5ee94c.tar.bz2
aports-d4cb60d815b65332d022275cb0eefa7fbf5ee94c.tar.xz
main/p11-kit: Ensure trust_paths is set
During the upgrade from `0.23.18.1-r0` to `0.23.20-r0` in commit 7aef1583c323ad5a6c6399fa75fb541b2710d3b8, the build system was changed from autotools to meson, but the `--with-trust-paths` option didn't get ported over to the meson equivalent. This caused commands, like `trust list`, to return no results, which causes Java issues due to `/etc/ssl/certs/java/cacerts` not being updated properly (#11185). This commit adds the meson `trust_paths` build variable so that p11-kit can find the proper CA certs file. Signed-off-by: Andrew Gunnerson <andrew.gunnerson@us.ibm.com>
Diffstat (limited to 'main')
-rw-r--r--main/p11-kit/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/p11-kit/APKBUILD b/main/p11-kit/APKBUILD
index c3110e6d31..2535cf7e2c 100644
--- a/main/p11-kit/APKBUILD
+++ b/main/p11-kit/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=p11-kit
pkgver=0.23.20
-pkgrel=0
+pkgrel=1
pkgdesc="Library for loading and sharing PKCS#11 modules"
url="https://p11-glue.freedesktop.org/"
arch="all"
@@ -14,6 +14,7 @@ source="https://github.com/p11-glue/p11-kit/releases/download/$pkgver/p11-kit-$p
build() {
meson \
--prefix=/usr \
+ -D trust_paths=/etc/ssl/certs/ca-certificates.crt \
. output
ninja -C output
}