aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-07-12 09:46:40 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-07-12 09:46:40 +0300
commitd90eb9a3e0bec8ca137329857de54e3fd7d1aeaa (patch)
tree1a71c042555982fd0e152ba40afc7d0c0ec000d9 /main
parent46edfde10d8e5baec6bfaef2fedc311108465d82 (diff)
downloadaports-d90eb9a3e0bec8ca137329857de54e3fd7d1aeaa.tar.bz2
aports-d90eb9a3e0bec8ca137329857de54e3fd7d1aeaa.tar.xz
main/perl-exception-class: upgrade to 1.43, modernize aport
Diffstat (limited to 'main')
-rw-r--r--main/perl-exception-class/APKBUILD39
1 files changed, 23 insertions, 16 deletions
diff --git a/main/perl-exception-class/APKBUILD b/main/perl-exception-class/APKBUILD
index 941fbb1fab..ccd540273c 100644
--- a/main/perl-exception-class/APKBUILD
+++ b/main/perl-exception-class/APKBUILD
@@ -1,41 +1,48 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 2
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=perl-exception-class
_pkgreal=Exception-Class
-pkgver=1.40
+pkgver=1.43
pkgrel=0
pkgdesc="A module that allows you to declare real exception classes in Perl"
url="http://search.cpan.org/dist/Exception-Class/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends="perl-devel-stacktrace perl-class-data-inheritable"
-cpanmakedepends=" "
+cpanmakedepends=""
+cpancheckdepends=""
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
+checkdepends="$cpancheckdepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/$_pkgreal-$pkgver.tar.gz"
-
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ default_prepare
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="07cd7a38be5f8134955e943cf666d453 Exception-Class-1.40.tar.gz"
-sha256sums="d1171f2d03a485e87eb561f34688991c17b939d2689bcda47f3f51b372669a1f Exception-Class-1.40.tar.gz"
-sha512sums="e70b0fc8c5696fcb9536d47ab003a61f5025c30937491172eae7c4975bdbd9d2e435cded09d02ddc4961d93afbd47a2c1d62a83a6173fb04f284de5abd056b1b Exception-Class-1.40.tar.gz"
+check() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+sha512sums="8416f82032dd39c38c9a4e12d7ae23cd0d66e1cbe9b22bde274972031c6218ed2d90cf9caf052a3d201decf92e715d0bf56a42789f35a7a60b9ea66680fb2668 Exception-Class-1.43.tar.gz"