aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-27 13:35:32 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-27 16:24:48 +0100
commitdcf1295dd9b83777c221e725bf095f49a00b27be (patch)
treef35b4bc067fc18c10ead496dd8cfe83d91480354 /main
parent86b1da5305deb4de3fed70b3150e8d37e3f3db62 (diff)
downloadaports-dcf1295dd9b83777c221e725bf095f49a00b27be.tar.bz2
aports-dcf1295dd9b83777c221e725bf095f49a00b27be.tar.xz
main/lxc: drop dependency on standalone xz for download utility
Busybox now provides their own xz applet which we can use instead
Diffstat (limited to 'main')
-rw-r--r--main/lxc/APKBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/main/lxc/APKBUILD b/main/lxc/APKBUILD
index 012b51357f..b80212ceb1 100644
--- a/main/lxc/APKBUILD
+++ b/main/lxc/APKBUILD
@@ -4,11 +4,11 @@
pkgname=lxc
pkgver=3.2.1
_pkgver=${pkgver/_rc/.rc}
-pkgrel=1
+pkgrel=2
pkgdesc="Userspace interface for the Linux kernel containment features"
url="https://linuxcontainers.org/lxc/"
arch="all"
-license="GPL"
+license="GPL-2.0-only"
makedepends="
libcap-dev
libcap-static
@@ -44,7 +44,6 @@ source="https://linuxcontainers.org/downloads/lxc/lxc-$_pkgver.tar.gz
lxc.initd
lxc.confd
"
-builddir="$srcdir/lxc-$_pkgver"
# secfixes:
# 3.1.0-r1:
@@ -56,7 +55,6 @@ builddir="$srcdir/lxc-$_pkgver"
_tmpldir="usr/share/lxc/templates"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -72,13 +70,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir" install
install -Dm755 "$srcdir"/lxc.initd "$pkgdir"/etc/init.d/lxc
@@ -105,7 +100,7 @@ _py3() {
_download() {
pkgdesc="LXC container image downloader template"
- depends="$pkgname gnupg1 tar xz wget"
+ depends="$pkgname gnupg1 tar wget"
mkdir -p "$subpkgdir"/$_tmpldir
mv "$pkgdir"/$_tmpldir/lxc-download "$subpkgdir"/$_tmpldir/