aboutsummaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-05-11 14:54:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-11 14:55:27 +0000
commiteecf0964ca464449d9fba05a93f31c9d61d28f31 (patch)
tree0019805fbf9bd0b0c2a1721a37326dda740934d2 /main
parente6c21189f58364d6f13ce073a417e701efa9da94 (diff)
downloadaports-eecf0964ca464449d9fba05a93f31c9d61d28f31.tar.bz2
aports-eecf0964ca464449d9fba05a93f31c9d61d28f31.tar.xz
main/postgresql: disable plperl to unblock the builders
plperl seems to be broken with perl 5.28. Disable so we unblock the builders while working on a proper fix.
Diffstat (limited to 'main')
-rw-r--r--main/postgresql/APKBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/main/postgresql/APKBUILD b/main/postgresql/APKBUILD
index 472139d7cd..108659327e 100644
--- a/main/postgresql/APKBUILD
+++ b/main/postgresql/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
pkgname=postgresql
pkgver=11.3
-pkgrel=0
+pkgrel=1
pkgdesc="A sophisticated object-relational DBMS"
url="https://www.postgresql.org/"
arch="all"
@@ -18,9 +18,9 @@ makedepends="$depends_dev libedit-dev zlib-dev libxml2-dev util-linux-dev
openldap-dev tcl-dev perl-dev python2-dev python3-dev"
subpackages="$pkgname-contrib $pkgname-dev $pkgname-doc libpq $pkgname-libs
$pkgname-client $pkgname-pltcl
- $pkgname-plperl $pkgname-plperl-contrib:plperl_contrib
$pkgname-plpython2 $pkgname-plpython2-contrib:plpython2_contrib
$pkgname-plpython3 $pkgname-plpython3-contrib:plpython3_contrib"
+# $pkgname-plperl $pkgname-plperl-contrib:plperl_contrib
source="https://ftp.postgresql.org/pub/source/v$pkgver/$pkgname-$pkgver.tar.bz2
initdb.patch
perl-rpath.patch
@@ -117,7 +117,7 @@ _configure() (
--with-openssl \
--with-uuid=e2fs \
--disable-rpath \
- --with-perl \
+ --without-perl \
--with-python \
--with-tcl
)
@@ -126,8 +126,7 @@ check() {
cd "$builddir"
_run_tests src/test
- # FIXEME: fix plperl which fails
- # _run_tests src/pl
+ _run_tests src/pl
_run_tests contrib
}