aboutsummaryrefslogtreecommitdiffstats
path: root/testing/abduco
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-01-09 12:52:12 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2016-01-09 16:07:56 +0100
commit13691005016314f3cf00bae93b7c6f7ae110a870 (patch)
treef2bd24d972af49ef80f2bd687652b16c7ab14741 /testing/abduco
parentef5c02e74c0c2822a43bb7282604aa68201f2671 (diff)
downloadaports-13691005016314f3cf00bae93b7c6f7ae110a870.tar.bz2
aports-13691005016314f3cf00bae93b7c6f7ae110a870.tar.xz
testing/abduco: new aport
Diffstat (limited to 'testing/abduco')
-rw-r--r--testing/abduco/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/abduco/APKBUILD b/testing/abduco/APKBUILD
new file mode 100644
index 0000000000..678619e634
--- /dev/null
+++ b/testing/abduco/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer:
+pkgname=abduco
+pkgver=0.5
+pkgrel=0
+pkgdesc="Session management in a clean and simple way"
+url="http://www.brain-dump.org/projects/abduco/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="http://www.brain-dump.org/projects/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ make -C "$_builddir" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" install || return 1
+ install -Dm644 README.md \
+ "$pkgdir"/usr/share/doc/$pkgname/README.md || return 1
+}
+
+md5sums="c1582411bc12f36620ec0e555da540fc abduco-0.5.tar.gz"
+sha256sums="bf22226a4488355a7001a5dabbd1e8e3b7e7645efd1519274b956fcb8bcff086 abduco-0.5.tar.gz"
+sha512sums="e0772b8eecc1fb6f16c7516a6956825b9bda4149f00f56b34e68ec3544f74c2270ba8cc2642599de26ae34d11ed78b8bba70497bfc9a79f3008f50de02ce49d8 abduco-0.5.tar.gz"