aboutsummaryrefslogtreecommitdiffstats
path: root/testing/acf-provisioning-grandstream-ata
diff options
context:
space:
mode:
authorSeung Soo Mun <hamletmun@gmail.com>2015-06-08 13:39:03 +0000
committerTed Trask <ttrask01@yahoo.com>2015-06-08 15:01:45 +0000
commit77217e460f06c8c75405d3de9d0db96b69f87577 (patch)
tree80db43387361cc11cc7a5d1230a4d84fee329fe5 /testing/acf-provisioning-grandstream-ata
parent1fd793386466c386c5b5b7374426a4b1e85af8b3 (diff)
downloadaports-77217e460f06c8c75405d3de9d0db96b69f87577.tar.bz2
aports-77217e460f06c8c75405d3de9d0db96b69f87577.tar.xz
testing: new aports for acf-provisioning: algo, cyberdata, grandstream-ata
Signed-off-by: Ted Trask <ttrask01@yahoo.com>
Diffstat (limited to 'testing/acf-provisioning-grandstream-ata')
-rw-r--r--testing/acf-provisioning-grandstream-ata/APKBUILD45
-rw-r--r--testing/acf-provisioning-grandstream-ata/init.cfg.sample73
2 files changed, 118 insertions, 0 deletions
diff --git a/testing/acf-provisioning-grandstream-ata/APKBUILD b/testing/acf-provisioning-grandstream-ata/APKBUILD
new file mode 100644
index 0000000000..ae9940a632
--- /dev/null
+++ b/testing/acf-provisioning-grandstream-ata/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Seung Soo Mun <hamletmun@gmail.com>
+# Maintainer: Ted Trask <ttrask01@yahoo.com>
+pkgname=acf-provisioning-grandstream-ata
+pkgver=1.0.7.3
+pkgrel=0
+pkgdesc="Files for provisioning Grandstream HandyTone products"
+url="http://www.grandstream.com/index.php/products"
+arch="noarch"
+license="AS IS"
+depends=""
+makedepends=""
+source="
+http://www.grandstream.com/firmware/GXW40xx_HT50x/Release_HT502_1.0.14.1.zip
+http://www.grandstream.com/firmware/GXW40xx_HT50x/Release_HT503_1.0.14.1.zip
+http://www.grandstream.com/firmware/HT70x/Release_HT701_1.0.7.3.zip
+http://www.grandstream.com/firmware/HT70x/Release_HT702_1.0.7.3.zip
+http://www.grandstream.com/firmware/HT70x/Release_HT704_1.0.7.3.zip
+init.cfg.sample"
+
+subpackages=""
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir"/var/www/provisioning/htdocs/Grandstream
+ cp *.cfg.sample *fw.bin "$pkgdir"/var/www/provisioning/htdocs/Grandstream
+}
+
+md5sums="45afec66616b94beb255d13376b0c1a6 Release_HT502_1.0.14.1.zip
+cf250b6bc7b7ac95223b63023f9f14c9 Release_HT503_1.0.14.1.zip
+40ed2488819b48bf207592b2feccd4e9 Release_HT701_1.0.7.3.zip
+1058fea95c6e7f9e1e257ab317ac9a90 Release_HT702_1.0.7.3.zip
+64210b2c52cbc42039c237ec8deaa903 Release_HT704_1.0.7.3.zip
+dada214a3a51fb69f27dfb746e3f5d10 init.cfg.sample"
+sha256sums="1c08eeae52b477e2028d2ce8b97cc66c2e0ab670c78576026b6a75b06157dfb0 Release_HT502_1.0.14.1.zip
+23500431b0a4a81b36e31a0926f82612246daf7ec18310fba6cd0c8c87fe0258 Release_HT503_1.0.14.1.zip
+bc3a5be33ee4c96685466ad67bf911e4b11a521d56e79747afa0d488ef6c6f6f Release_HT701_1.0.7.3.zip
+67544b68778cb3e87a0ccd5b07e6a34e707368c1c1c896d336655ccaf27981f6 Release_HT702_1.0.7.3.zip
+71abcd72e89550c7de85034ae1b869ee9f06218304f0002213897480716655c4 Release_HT704_1.0.7.3.zip
+0525a686672fd7080a4cfb76f5d466c172c8b6f50d507fd4be35fbab6ff413e2 init.cfg.sample"
+sha512sums="28e924c9995cdfbc3b3c632e9dc3a67b0b919d1af1ed543579bb8bd45fad4c0286ef24b09ac0d4302cb585362d138d88f85fb2dc645ff126e9756c9659cf2541 Release_HT502_1.0.14.1.zip
+9abc4c9356bbea404a2e5d6de62ad500365e6d019abc38d95802972dcba59a80c4b67a8acb5598aa68a97e7349c71150db65d7b2521fe3e347f625bde76088a2 Release_HT503_1.0.14.1.zip
+6cc5c17dd94efa9aface1a3f2b098d11798ae7dfbbcfdf69182b0784ac1fcb6c99138e215378aa9712f6fc3764c55e17bfe33c415d1cd67ce47cefe95491f2d6 Release_HT701_1.0.7.3.zip
+ccbf52d9530c3a88294764a8de8e36d0dc21f50c84be269c6ae5ee1bf0b1f404682db534fdbbb402588b7924d0cac865bec72145314db979b993b84c6d535e3d Release_HT702_1.0.7.3.zip
+4b6e999ebb7ad357b8026f6a0635500b34ff7d74c0ffc76f6e5b9c2f1e079ec8cd5dabd099cbce976f204b814ea20acf36e1d51a88b0676b124e0ad18ef55722 Release_HT704_1.0.7.3.zip
+a19a8b174f65603879420fdde77a70534bae6b03f1c11c28a83fd63a55252e11cfc8e4fd821b97d8ec742321bcdc6e1299155cd112bff8e7435f1703e2adbcff init.cfg.sample"
diff --git a/testing/acf-provisioning-grandstream-ata/init.cfg.sample b/testing/acf-provisioning-grandstream-ata/init.cfg.sample
new file mode 100644
index 0000000000..3fa43d4f25
--- /dev/null
+++ b/testing/acf-provisioning-grandstream-ata/init.cfg.sample
@@ -0,0 +1,73 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<gs_provision version="1">
+ <config version="1">
+
+<!-- Advanced Settings -->
+
+ <!-- HT-502 - Layer 3 QoS (IP Diff-Serv or Precedence value for RTP) -->
+ <P38>46</P38>
+ <!-- Layer 2 QoS. 802.1Q/VLAN Tag -->
+ <P51>1</P51>
+ <!-- HT-502 - Layer 2 QoS. 802.1p priority value -->
+ <P87>5</P87>
+ <!-- HT-701 - Layer 2 QoS. SIP 802.1p priority value -->
+ <P5038>5</P5038>
+ <!-- HT-701 - Layer 2 QoS. RTP 802.1p priority value -->
+ <P5042>5</P5042>
+
+ <!-- Firmware Upgrade and Provisioning. 0 - TFTP, 1 - HTTP, 2 - HTTPS
+ <P212>1</P4428>
+ <!-- Firmware Server Path -->
+ <P192>10.0.0.1/Grandstream</P192>
+ <!-- Config Server Path -->
+ <P237>10.0.0.1/Grandstream</P237>
+ <!-- Allow DHCP Option 66 to override server -->
+ <P145>0</P145>
+
+ <!-- Disable SIP NOTIFY Authentication -->
+ <P4428>1</P4428>
+ <!-- Disable Direct IP Call -->
+ <P277>1</P277>
+
+<!-- FXS Port 1 -->
+
+ <!-- DNS Mode: NAPTR/SRV -->
+ <P103>2</P103>
+ <!-- Refer-To Use Target Contact -->
+ <P135>1</P135>
+ <!-- Disable Call-Waiting -->
+ <P91>1</P91>
+ <!-- Delayed Call Forward Wait Time -->
+ <P139>120</P139>
+ <!-- Fax Mode: Pass Through -->
+ <P228>1</P228>
+
+<!-- FXS Port 2 -->
+
+ <!-- DNS Mode: NAPTR/SRV -->
+ <P702>2</P702>
+ <!-- Refer-To Use Target Contact -->
+ <P469>1</P469>
+ <!-- Disable Call-Waiting -->
+ <P791>1</P791>
+ <!-- Delayed Call Forward Wait Time -->
+ <P470>120</P470>
+ <!-- Fax Mode: Pass Through -->
+ <P710>1</P710>
+
+<!-- Basic Settings -->
+
+ <!-- Telnet Server: No -->
+ <P276>1</P276>
+ <!-- Reply to ICMP on WAN port -->
+ <P189>1</P189>
+ <!-- WAN side HTTP/Telnet access -->
+ <P190>1</P190>
+ <!-- Enable LAN DHCP -->
+ <P5001>0</P5001>
+
+ <!-- Time Zone -->
+ <P64>customize</P64>
+
+ </config>
+</gs_provision>