aboutsummaryrefslogtreecommitdiffstats
path: root/testing/agg
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /testing/agg
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'testing/agg')
-rw-r--r--testing/agg/APKBUILD43
-rw-r--r--testing/agg/agg-2.4-depends.patch48
-rw-r--r--testing/agg/agg-2.5-pkgconfig.patch10
3 files changed, 0 insertions, 101 deletions
diff --git a/testing/agg/APKBUILD b/testing/agg/APKBUILD
deleted file mode 100644
index 91e5d27f75..0000000000
--- a/testing/agg/APKBUILD
+++ /dev/null
@@ -1,43 +0,0 @@
-# Contributor: Elizabeth Jennifer Myers <elizabeth@sporksirc.net>
-# Maintainer: Elizabeth Jennifer Myers <elizabeth@sporksirc.net>
-pkgname=agg
-pkgver=2.5
-pkgrel=3
-pkgdesc="A Rendering Engine for C++"
-url="http://antigrain.com"
-license="GPL2+"
-depends=""
-makedepends="autoconf automake libtool libx11-dev freetype-dev sdl-dev"
-install=""
-arch="all"
-subpackages="$pkgname-dev"
-source="http://www.antigrain.com/$pkgname-$pkgver.tar.gz
- agg-2.4-depends.patch
- agg-2.5-pkgconfig.patch"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd $_builddir
- for i in "$srcdir"/*.patch; do
- msg "Applying ${i}"
- patch -Np1 -i "$i" || return 1
- done
- # fix building against automake-1.12
- sed -i '/^AM_C_PROTOTYPES/d' configure.in
- sh ./autogen.sh || return 1
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr --disable-static || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="${pkgdir}" install || return 1
-}
-
-md5sums="0229a488bc47be10a2fee6cf0b2febd6 agg-2.5.tar.gz
-22f8e48c137d25038181c86d5e40b110 agg-2.4-depends.patch
-43a19a7b1564c591e56c8d09a0fd8da5 agg-2.5-pkgconfig.patch"
diff --git a/testing/agg/agg-2.4-depends.patch b/testing/agg/agg-2.4-depends.patch
deleted file mode 100644
index 9d4f6e309d..0000000000
--- a/testing/agg/agg-2.4-depends.patch
+++ /dev/null
@@ -1,48 +0,0 @@
---- agg-2.4.orig/font_freetype/Makefile.am 2005-10-18 11:45:40.000000000 +0100
-+++ agg-2.4/font_freetype/Makefile.am 2006-07-10 15:11:55.000000000 +0100
-@@ -4,8 +4,9 @@
- agginclude_HEADERS = agg_font_freetype.h
- lib_LTLIBRARIES = libaggfontfreetype.la
-
--libaggfontfreetype_la_LDFLAGS = -version-info @AGG_LIB_VERSION@ @FREETYPE_LIBS@
-+libaggfontfreetype_la_LDFLAGS = -version-info @AGG_LIB_VERSION@
- libaggfontfreetype_la_SOURCES = agg_font_freetype.cpp
- libaggfontfreetype_la_CXXFLAGS = -I$(top_srcdir)/include @FREETYPE_CFLAGS@
-+libaggfontfreetype_la_LIBADD = ../src/libagg.la @FREETYPE_LIBS@
- endif
-
---- agg-2.4.orig/src/platform/sdl/Makefile.am 2005-10-17 23:49:35.000000000 +0100
-+++ agg-2.4/src/platform/sdl/Makefile.am 2006-07-10 15:11:55.000000000 +0100
-@@ -5,6 +5,6 @@
- libaggplatformsdl_la_LDFLAGS = -version-info @AGG_LIB_VERSION@
- libaggplatformsdl_la_SOURCES = agg_platform_support.cpp
- libaggplatformsdl_la_CXXFLAGS = -I$(top_srcdir)/include @SDL_CFLAGS@
--libaggplatformsdl_la_LIBADD = @SDL_LIBS@
-+libaggplatformsdl_la_LIBADD = ../../libagg.la @SDL_LIBS@
- endif
-
---- agg-2.5.orig/configure.in 2006-10-09 05:06:36.000000000 +0100
-+++ agg-2.5/configure.in 2007-01-07 14:07:39.000000000 +0000
-@@ -122,7 +122,8 @@
- fi
- AM_CONDITIONAL(ENABLE_X11,[test x$no_x = x -a xno != x$enable_platform -a x$win32_host != xyes])
- AC_SUBST(x_includes)
--AC_SUBST(x_libraries)
-+test -n "$x_libraries" && X_LDFLAGS="-L$x_libraries"
-+AC_SUBST(X_LDFLAGS)
- dnl ###############################################
-
- dnl Settung up library version
---- agg-2.5.orig/src/platform/X11/Makefile.am 2006-12-11 00:59:45.000000000 +0000
-+++ agg-2.5/src/platform/X11/Makefile.am 2007-01-07 14:07:39.000000000 +0000
-@@ -1,8 +1,8 @@
- if ENABLE_X11
- lib_LTLIBRARIES = libaggplatformX11.la
-
--libaggplatformX11_la_LDFLAGS = -version-info @AGG_LIB_VERSION@ -L@x_libraries@
-+libaggplatformX11_la_LDFLAGS = -version-info @AGG_LIB_VERSION@ @X_LDFLAGS@
- libaggplatformX11_la_SOURCES = agg_platform_support.cpp
- libaggplatformX11_la_CXXFLAGS = -I$(top_srcdir)/include -I@x_includes@
--libaggplatformX11_la_LIBADD = -lX11
-+libaggplatformX11_la_LIBADD = ../../libagg.la -lX11
- endif
diff --git a/testing/agg/agg-2.5-pkgconfig.patch b/testing/agg/agg-2.5-pkgconfig.patch
deleted file mode 100644
index a303bfb905..0000000000
--- a/testing/agg/agg-2.5-pkgconfig.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- agg-2.5/libagg.pc.in.orig 2007-01-07 13:58:28.000000000 +0000
-+++ agg-2.5/libagg.pc.in 2007-01-07 14:02:40.000000000 +0000
-@@ -6,5 +6,6 @@
- Name: libagg
- Description: Anti Grain Geometry - A High Quality Rendering Engine for C++
- Version: @VERSION@
--Libs: -L${libdir} -Wl,-rpath,${exec_prefix}/lib -lagg
-+Requires.private: freetype2
-+Libs: -L${libdir} -lagg
- Cflags: -I${includedir}