aboutsummaryrefslogtreecommitdiffstats
path: root/testing/altermime/makefile-flags.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-02 12:41:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-02 12:41:02 +0000
commite390bd27058427d609420a460762668888a8888e (patch)
tree585d5367143115f3b6b689fb6726e55559eb072c /testing/altermime/makefile-flags.patch
parent642b6ca55982105ad3e59b0fa5aff8c43111ecb0 (diff)
downloadaports-e390bd27058427d609420a460762668888a8888e.tar.bz2
aports-e390bd27058427d609420a460762668888a8888e.tar.xz
testing/altermime: new aport
program alter mime-encoded mailpacks http://www.pldaniels.com/altermime/
Diffstat (limited to 'testing/altermime/makefile-flags.patch')
-rw-r--r--testing/altermime/makefile-flags.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/testing/altermime/makefile-flags.patch b/testing/altermime/makefile-flags.patch
new file mode 100644
index 0000000000..71a399051e
--- /dev/null
+++ b/testing/altermime/makefile-flags.patch
@@ -0,0 +1,21 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -9,7 +9,8 @@
+ # opposite of a disclaimer.
+ #ALTERMIME_OPTIONS=-DALTERMIME_PRETEXT
+ ALTERMIME_OPTIONS=
+-CFLAGS=-Wall -Werror -g -I. -O2 $(ALTERMIME_OPTIONS)
++CFLAGS?=-Wall -Werror -g -I. -O2
++CFLAGS+=$(ALTERMIME_OPTIONS)
+ OBJS= strstack.o mime_alter.o ffget.o pldstr.o filename-filters.o logger.o MIME_headers.o libmime-decoders.o boundary-stack.o qpe.o
+
+
+@@ -19,7 +20,7 @@
+ all: altermime
+
+ altermime: altermime.c ${OBJS}
+- ${CC} ${CFLAGS} altermime.c ${OBJS} -o altermime
++ ${CC} ${CFLAGS} altermime.c ${OBJS} ${LDFLAGS} -o altermime
+
+
+ # Build Install