aboutsummaryrefslogtreecommitdiffstats
path: root/testing/apache2-mod-authnz-external
diff options
context:
space:
mode:
authorNHellFire <nathan.renniewaldock@gmail.com>2017-05-20 06:41:36 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-06 19:51:06 +0000
commit47084181b5e67ebb55c17adb6b276bb8fcde8ce6 (patch)
tree3e139ea772a9c240604fdf7e7bbdbf8c0864c4a6 /testing/apache2-mod-authnz-external
parent81f22982dde431461e6c78e2e6ce7bc8f8921d6e (diff)
downloadaports-47084181b5e67ebb55c17adb6b276bb8fcde8ce6.tar.bz2
aports-47084181b5e67ebb55c17adb6b276bb8fcde8ce6.tar.xz
testing/apache2-mod-authnz-external: new aport
https://code.google.com/p/mod-auth-external/ Apache module for external authentication
Diffstat (limited to 'testing/apache2-mod-authnz-external')
-rw-r--r--testing/apache2-mod-authnz-external/APKBUILD42
-rw-r--r--testing/apache2-mod-authnz-external/apache2-mod-authnz-external.apache2.conf1
2 files changed, 43 insertions, 0 deletions
diff --git a/testing/apache2-mod-authnz-external/APKBUILD b/testing/apache2-mod-authnz-external/APKBUILD
new file mode 100644
index 0000000000..8f36bb79ad
--- /dev/null
+++ b/testing/apache2-mod-authnz-external/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Nathan Rennie-Waldock <nathan.renniewaldock@gmail.com>
+# Maintainer: Nathan Rennie-Waldock <nathan.renniewaldock@gmail.com>
+pkgname=apache2-mod-authnz-external
+_realname=mod_authnz_external
+pkgver=3.3.2
+pkgrel=0
+pkgdesc="Apache module for external authentication"
+url="https://code.google.com/p/mod-auth-external/"
+arch="all"
+license="ASL 2.0"
+depends="apache2"
+makedepends="apache2-dev"
+install=""
+subpackages="$pkgname-doc"
+source="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/mod-auth-external/$_realname-$pkgver.tar.gz
+ $pkgname.apache2.conf"
+builddir="$srcdir/$_realname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make || return 1
+
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 ".libs/$_realname.so" "$pkgdir/usr/lib/apache2/$_realname.so"
+ install -Dm644 "$srcdir/$pkgname.apache2.conf" \
+ "$pkgdir/etc/apache2/conf.d/authnz-external-module.conf" || return 1
+ local f
+ for f in AUTHENTICATORS README; do
+ install -Dm644 "$f" \
+ "$pkgdir/usr/share/doc/$pkgname/$f" || return 1
+ done
+}
+
+md5sums="34981f7f26abfc8d71c93391e15d679c mod_authnz_external-3.3.2.tar.gz
+86f27d2072039fb1f8f37e8e8981343e apache2-mod-authnz-external.apache2.conf"
+sha256sums="a16b31d81c20e024e7efe480fe98b48d5ce40d520b0a13ff38ab003cc527f1e8 mod_authnz_external-3.3.2.tar.gz
+c43a8f06c96eee433f96e00c52961f60e9c4b1db3ac62f1c815f9142629c5861 apache2-mod-authnz-external.apache2.conf"
+sha512sums="8216744dbaed8dbde0d33658e38594463409e613412bd94f3e5f5a816f5e793a395ddda7c582ff1d1e69e48efdd1efb48c168d4cbc37cc7807a0dcb92eace0be mod_authnz_external-3.3.2.tar.gz
+aad10cd570ae77b24a658898f1edb0ee08501e98ef76b68efd101037f53b7de123aecc87e535957b401925c665f952b381c4d4bf874c946ba0caeb979b222c35 apache2-mod-authnz-external.apache2.conf"
diff --git a/testing/apache2-mod-authnz-external/apache2-mod-authnz-external.apache2.conf b/testing/apache2-mod-authnz-external/apache2-mod-authnz-external.apache2.conf
new file mode 100644
index 0000000000..3f2b82da53
--- /dev/null
+++ b/testing/apache2-mod-authnz-external/apache2-mod-authnz-external.apache2.conf
@@ -0,0 +1 @@
+LoadModule authnz_external_module modules/mod_authnz_external.so