aboutsummaryrefslogtreecommitdiffstats
path: root/testing/apache2-mod-perl
diff options
context:
space:
mode:
authorMatt Smith <mcs@darkregion.net>2011-04-12 02:39:33 -0500
committerMatt Smith <mcs@darkregion.net>2011-04-12 02:40:19 -0500
commit53910ad269e87131ee1096e651743b88f69aadfe (patch)
treefcc06361ba0dedf12db5d4307809bff6e2707c12 /testing/apache2-mod-perl
parentc42298ac37128c5ebc1b68399d1ef15908a1134a (diff)
downloadaports-53910ad269e87131ee1096e651743b88f69aadfe.tar.bz2
aports-53910ad269e87131ee1096e651743b88f69aadfe.tar.xz
testing/apache2-mod-perl: new aport
Perl Module for Apache2 http://perl.apache.org/
Diffstat (limited to 'testing/apache2-mod-perl')
-rw-r--r--testing/apache2-mod-perl/APKBUILD58
-rw-r--r--testing/apache2-mod-perl/apache2-mod-perl.apache2.conf11
-rw-r--r--testing/apache2-mod-perl/apache2-mod-perl.post-install10
3 files changed, 79 insertions, 0 deletions
diff --git a/testing/apache2-mod-perl/APKBUILD b/testing/apache2-mod-perl/APKBUILD
new file mode 100644
index 0000000000..43ffe184d7
--- /dev/null
+++ b/testing/apache2-mod-perl/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: Matt Smith <mcs@darkregion.net>
+# Maintainer: Matt Smith <mcs@darkregion.net>
+pkgname=apache2-mod-perl
+_realname=mod_perl
+pkgver=2.0.5
+pkgrel=0
+pkgdesc="Perl Module for Apache2"
+url="http://perl.apache.org/"
+arch="all"
+license="APACHE"
+depends="apache2 perl"
+depends_dev=
+makedepends="$depends_dev apache2-dev perl-dev"
+install="$pkgname.post-install"
+subpackages="$pkgname-doc $pkgname-dev"
+source="http://search.cpan.org/CPAN/authors/id/P/PH/PHRED/${_realname}-${pkgver}.tar.gz
+ $pkgname.apache2.conf
+ "
+
+_builddir="$srcdir"/${_realname}-${pkgver}
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor \
+ MP_APXS=/usr/sbin/apxs || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+
+ # install the apache2 config
+ install -Dm644 "$srcdir"/$pkgname.apache2.conf \
+ "$pkgdir"/etc/apache2/conf.d/perl-module.conf || return 1
+}
+
+doc() {
+ arch="noarch"
+
+ # man pages
+ mkdir -p "$subpkgdir"/usr/share/man || return 1
+ mv "$pkgdir"/usr/share/man/man* "$subpkgdir"/usr/share/man/ \
+ || return 1
+
+ # doc files
+ _docs="BRANCHING Changes INSTALL LICENSE MANIFEST NOTICE README \
+ README-SVN RELEASE STATUS SVN-MOVE"
+ for _doc in $_docs; do
+ install -Dm644 "$_builddir"/$_doc \
+ "$subpkgdir"/usr/share/doc/$pkgname/$_doc || return 1
+ done
+ cp -ra "$_builddir"/docs/ "$subpkgdir"/usr/share/doc/$pkgname/ \
+ || return 1
+}
+
+md5sums="03d01d135a122bd8cebd0cd5b185d674 mod_perl-2.0.5.tar.gz
+86b84bb56b49a95772a7f773fc019043 apache2-mod-perl.apache2.conf"
diff --git a/testing/apache2-mod-perl/apache2-mod-perl.apache2.conf b/testing/apache2-mod-perl/apache2-mod-perl.apache2.conf
new file mode 100644
index 0000000000..c1a75c76ff
--- /dev/null
+++ b/testing/apache2-mod-perl/apache2-mod-perl.apache2.conf
@@ -0,0 +1,11 @@
+LoadModule perl_module modules/mod_perl.so
+
+# For mod_perl 1.0 compatibility, uncomment:
+#PerlModule Apache2::compat
+
+<Location /cgi-bin>
+ AddHandler perl-script .pl
+ PerlResponseHandler ModPerl::Registry
+ PerlOptions +ParseHeaders
+ Options +ExecCGI
+</Location>
diff --git a/testing/apache2-mod-perl/apache2-mod-perl.post-install b/testing/apache2-mod-perl/apache2-mod-perl.post-install
new file mode 100644
index 0000000000..8cfc5a86e4
--- /dev/null
+++ b/testing/apache2-mod-perl/apache2-mod-perl.post-install
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+echo "*" >&2
+echo "* To finish installing apache2-mod-perl:" >&2
+echo "* 1) See if you need to modify the apache2 config:" >&2
+echo "* /etc/apache2/conf.d/perl-module.conf" >&2
+echo "* 2) Restart apache2 when done." >&2
+echo "*" >&2
+
+exit 0