aboutsummaryrefslogtreecommitdiffstats
path: root/testing/appstream
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-27 23:13:18 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-28 14:55:47 -0300
commit70acd16c277ef98ae06cf0b028fa762e37e8de17 (patch)
tree4f7af85ff76c1e77b5bc8527783ba624b21b6cb9 /testing/appstream
parentb42bff67f2fc532fc9f7ae48967e05667f6fabcb (diff)
downloadaports-70acd16c277ef98ae06cf0b028fa762e37e8de17.tar.bz2
aports-70acd16c277ef98ae06cf0b028fa762e37e8de17.tar.xz
testing/appstream: new aport
https://distributions.freedesktop.org/wiki/AppStream Provides a standard for creating app stores across distributions
Diffstat (limited to 'testing/appstream')
-rw-r--r--testing/appstream/APKBUILD52
-rw-r--r--testing/appstream/appstream.post-install6
-rw-r--r--testing/appstream/appstream.post-upgrade6
-rw-r--r--testing/appstream/appstream.trigger4
4 files changed, 68 insertions, 0 deletions
diff --git a/testing/appstream/APKBUILD b/testing/appstream/APKBUILD
new file mode 100644
index 0000000000..298fe73a64
--- /dev/null
+++ b/testing/appstream/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=appstream
+pkgver=0.12.8
+pkgrel=0
+pkgdesc="Provides a standard for creating app stores across distributions"
+url="https://distributions.freedesktop.org/wiki/AppStream"
+arch="all"
+license="LGPL-2.1-or-later AND GPL-2.0-or-later"
+makedepends="meson yaml-dev libxml2-dev glib-dev lmdb-dev gobject-introspection-dev
+ gperf qt5-qtbase-dev"
+triggers="$pkgname.trigger=/usr/share/app-info/*"
+install="$pkgname.post-install $pkgname.post-upgrade"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-qt $pkgname-lang"
+source="https://www.freedesktop.org/software/appstream/releases/AppStream-$pkgver.tar.xz"
+builddir="$srcdir/AppStream-$pkgver"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ -Dqt=true \
+ -Ddocs=false \
+ -Dapidocs=false \
+ -Dinstall-docs=false \
+ -Dstemming=false \
+ -Dvapi=false \
+ -Dapt-support=false \
+ -Dgir=true \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+qt() {
+ pkgdesc="Qt5 interface for AppStream"
+ license="LGPL-2.1-or-later"
+
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libAppStreamQt.so.* "$subpkgdir"/usr/lib
+}
+sha512sums="4354ef1840d919102647feffc38687f508b14fe9c047c868448347d888aa821dd8a4d25787a2ffb55247f8e9e20e9e03ba330ad74ad61d476be0c414c04a7c30 AppStream-0.12.8.tar.xz"
diff --git a/testing/appstream/appstream.post-install b/testing/appstream/appstream.post-install
new file mode 100644
index 0000000000..5a63845bb8
--- /dev/null
+++ b/testing/appstream/appstream.post-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+umask 022
+/usr/bin/appstreamcli refresh-cache --force
+
+exit 0
diff --git a/testing/appstream/appstream.post-upgrade b/testing/appstream/appstream.post-upgrade
new file mode 100644
index 0000000000..5a63845bb8
--- /dev/null
+++ b/testing/appstream/appstream.post-upgrade
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+umask 022
+/usr/bin/appstreamcli refresh-cache --force
+
+exit 0
diff --git a/testing/appstream/appstream.trigger b/testing/appstream/appstream.trigger
new file mode 100644
index 0000000000..51f6d89acd
--- /dev/null
+++ b/testing/appstream/appstream.trigger
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+umask 022
+/usr/bin/appstreamcli refresh-cache --force