aboutsummaryrefslogtreecommitdiffstats
path: root/testing/atomicparsley/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-05 03:34:39 -0300
committerFrancesco Colista <fcolista@alpinelinux.org>2019-06-05 07:19:07 +0000
commit9aff193e6b30a5fd0f818dd79ea083bc70d64527 (patch)
tree0cb67fdc0b67a843efc31d53da7f25c4759156ff /testing/atomicparsley/APKBUILD
parente9ef2f8eadee67fce9cb5a06ef88b48a5ff82c20 (diff)
downloadaports-9aff193e6b30a5fd0f818dd79ea083bc70d64527.tar.bz2
aports-9aff193e6b30a5fd0f818dd79ea083bc70d64527.tar.xz
testing/atomicparsley: modernize, fix url, fix license
Diffstat (limited to 'testing/atomicparsley/APKBUILD')
-rw-r--r--testing/atomicparsley/APKBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/testing/atomicparsley/APKBUILD b/testing/atomicparsley/APKBUILD
index 34ac6a1504..b26dd2257e 100644
--- a/testing/atomicparsley/APKBUILD
+++ b/testing/atomicparsley/APKBUILD
@@ -3,36 +3,32 @@
pkgname=atomicparsley
pkgver=0.9.6
_gittag=da2f6e4fc120
-pkgrel=0
+pkgrel=1
pkgdesc="A command line program for reading, parsing and setting iTunes-style metadata in MPEG4 files"
-url="https://atomicparsley.sourceforge.net/"
+url="http://atomicparsley.sourceforge.net/"
arch="all"
-license="GPL"
+license="GPL-2.0-or-later"
makedepends="automake autoconf libtool zlib-dev linux-headers"
source="$pkgname-$pkgver.tar.gz::https://bitbucket.org/wez/atomicparsley/get/$pkgver.tar.gz
-musl-fpos_t.patch
-"
+ musl-fpos_t.patch
+ "
builddir="$srcdir/wez-$pkgname-$_gittag"
prepare() {
default_prepare
- cd "$builddir"
./autogen.sh
}
build() {
- cd "$builddir"
./configure --prefix=/usr
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}