aboutsummaryrefslogtreecommitdiffstats
path: root/testing/badwolf
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2019-12-26 02:44:04 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-12-30 23:34:09 +0100
commit320ce2cb638bf088e59852be6c21ad4092c54581 (patch)
treeab8dea4fc2505ed543e6df20b6018c3b64cfbdc0 /testing/badwolf
parentce11c94016e7f5064e50ba9cac8bbfdbd64f59ae (diff)
downloadaports-320ce2cb638bf088e59852be6c21ad4092c54581.tar.bz2
aports-320ce2cb638bf088e59852be6c21ad4092c54581.tar.xz
testing/badwolf: new aport
https://hacktivis.me/projects/badwolf Minimalist and privacy-oriented WebKitGTK+ browser
Diffstat (limited to 'testing/badwolf')
-rw-r--r--testing/badwolf/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/badwolf/APKBUILD b/testing/badwolf/APKBUILD
new file mode 100644
index 0000000000..f42381da72
--- /dev/null
+++ b/testing/badwolf/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Haelwenn (lanodan) Monnier <contact+alpine@hacktivis.me>
+pkgname=badwolf
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="A minimalist and privacy-oriented WebKit browser"
+url="https://hacktivis.me/projects/badwolf"
+arch="all"
+license="BSD-3-Clause"
+makedepends="webkit2gtk-dev"
+subpackages="$pkgname-doc"
+options="!check" # unit tests coming in next release
+source="https://hacktivis.me/releases/badwolf-$pkgver.tar.gz"
+
+build() {
+ make PREFIX=/usr CFLAGS="$CFLAGS"
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+sha512sums="572e1c18223ded5989da9c47e42c9dcbf66903e38b672e33b098cc3f84965d9da8e0a8b71e5ec88f17879c8d2f931d9625ca26a9c5ae81cc925d62fbf2abd4f1 badwolf-0.4.0.tar.gz"