aboutsummaryrefslogtreecommitdiffstats
path: root/testing/belle-sip
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-07-03 06:40:34 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-07-03 06:40:39 +0000
commit15e2f6094ec5928728d148933499132fc0220b8a (patch)
treedd1485302c4ad38c7aae5899d9032aab2a426f9b /testing/belle-sip
parent5b5d60eca80bc09801f97eeb0caf412f410fea6f (diff)
downloadaports-15e2f6094ec5928728d148933499132fc0220b8a.tar.bz2
aports-15e2f6094ec5928728d148933499132fc0220b8a.tar.xz
testing/belle-sip: new aport
Diffstat (limited to 'testing/belle-sip')
-rw-r--r--testing/belle-sip/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/belle-sip/APKBUILD b/testing/belle-sip/APKBUILD
new file mode 100644
index 0000000000..96d59e5be4
--- /dev/null
+++ b/testing/belle-sip/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname="belle-sip"
+pkgver="1.6.3"
+_pkgver=${pkgver}-0
+pkgrel=0
+pkgdesc="SIP (RFC3261) implementation written in C"
+url="https://www.linphone.org"
+arch="all"
+license="GPL-2.0-or-later"
+options="!check" # no test available
+makedepends="cmake libantlr3c libantlr3c-dev bctoolbox-dev
+zlib-dev mbedtls-dev openjdk10-jre-headless"
+subpackages="$pkgname-dev"
+source="https://www.linphone.org/releases/sources/${pkgname}/${pkgname}-${pkgver}.tar.gz
+antlr.jar::https://github.com/antlr/website-antlr3/blob/gh-pages/download/antlr-3.4-complete.jar?raw=true"
+builddir="$srcdir/$pkgname-$_pkgver"
+
+build() {
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_MODULE_PATH=/usr/lib/cmake \
+ -DCMAKE_SKIP_INSTALL_RPATH=ON \
+ -DENABLE_STATIC=NO \
+ -DENABLE_SHARED=YES \
+ -DENABLE_TESTS=YES \
+ -DENABLE_STRICT=NO \
+ -DANTLR3_JAR_PATH="$srcdir"/antlr.jar .
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+dev() {
+ default_dev
+ mkdir -p "$subpkgdir"/usr/lib/cmake/BelleSIP
+ mv "$pkgdir"/usr/share/BelleSIP/cmake/* "$subpkgdir"/usr/lib/cmake/BelleSIP
+}
+
+sha512sums="4f7049a06195a702a424fbec1671dc5075c3fbcd3fbb9dd990c15115d291ffcbde2b47440c479ef45d0f3251fa75774729c6a11ff1826adb53359c61e80c5df2 belle-sip-1.6.3.tar.gz
+04be4dfba3a21f3ab9d9e439a64958bd8e844a9f151b798383bd9e0dd6ebc416783ae7cb1d1dbb27fb7288ab9756b13b8338cdb8ceb41a10949c852ad45ab1f2 antlr.jar"