aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bfs
diff options
context:
space:
mode:
authorTavian Barnes <tavianator@tavianator.com>2018-03-12 17:15:47 -0400
committerSören Tempel <soeren+git@soeren-tempel.net>2018-03-19 21:21:19 +0100
commit45b93e6213bcea1d0d57c550c44907313cd51fb6 (patch)
tree95e63d656512b7abbfdbf0c3ae7e6580b7f207e0 /testing/bfs
parentdff2946bdbf31667d04f9897da667a429fb3f1a5 (diff)
downloadaports-45b93e6213bcea1d0d57c550c44907313cd51fb6.tar.bz2
aports-45b93e6213bcea1d0d57c550c44907313cd51fb6.tar.xz
testing/bfs: invoke upstream testsuite in check
Diffstat (limited to 'testing/bfs')
-rw-r--r--testing/bfs/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/bfs/APKBUILD b/testing/bfs/APKBUILD
index 2aed4a9ede..2384bd76ed 100644
--- a/testing/bfs/APKBUILD
+++ b/testing/bfs/APKBUILD
@@ -8,7 +8,9 @@ url="https://github.com/tavianator/bfs"
arch="all"
license="0BSD"
makedepends="linux-headers"
+checkdepends="bash coreutils diffutils"
subpackages="$pkgname-doc"
+options="!checkroot"
source="$pkgname-$pkgver.tar.gz::https://github.com/tavianator/$pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
@@ -17,8 +19,7 @@ build() {
}
check() {
- cd "$builddir"
- ./bfs -nohidden > /dev/null
+ make -C "$builddir" check
}
package() {