aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bfs
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-07-15 22:09:20 +0300
committerTimo Teräs <timo.teras@iki.fi>2018-07-19 10:38:35 +0000
commitd72d6c58f31a40d5aa7e604ad06fb131a513f55b (patch)
tree576af2115c4daa7c672ed4e8d0881c6cc65f793b /testing/bfs
parentf6f3916792864a24bf2211f107e673d6a80cb643 (diff)
downloadaports-d72d6c58f31a40d5aa7e604ad06fb131a513f55b.tar.bz2
aports-d72d6c58f31a40d5aa7e604ad06fb131a513f55b.tar.xz
testing/bfs: upgrade to 1.2.3
Diffstat (limited to 'testing/bfs')
-rw-r--r--testing/bfs/APKBUILD10
-rw-r--r--testing/bfs/fix_headroom.patch20
2 files changed, 4 insertions, 26 deletions
diff --git a/testing/bfs/APKBUILD b/testing/bfs/APKBUILD
index a436514ccd..a43bac8d18 100644
--- a/testing/bfs/APKBUILD
+++ b/testing/bfs/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: dai9ah <dai9ah@protonmail.com>
# Maintainer: dai9ah <dai9ah@protonmail.com>
pkgname=bfs
-pkgver=1.2.2
-pkgrel=1
+pkgver=1.2.3
+pkgrel=0
pkgdesc="Breadth-first variant of the UNIX find command"
url="https://github.com/tavianator/bfs"
arch="all"
@@ -11,8 +11,7 @@ makedepends="linux-headers"
checkdepends="bash"
subpackages="$pkgname-doc"
options="!checkroot"
-source="$pkgname-$pkgver.tar.gz::https://github.com/tavianator/$pkgname/archive/$pkgver.tar.gz
- fix_headroom.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tavianator/bfs/archive/$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -30,5 +29,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="ec78687b1c3d62e1f625b18d2f668f91663425db634cbb540c0e06b279702d1b9ffb88eddb35db229839ba85eac788416f059a65887a313409d6c3be281bb331 bfs-1.2.2.tar.gz
-dde2977ef90f4e53bbb2de41b93de4fc921d366eaedff0f1d6b3dc17ad3336b0c7957feccaa1a8c33545ac33208c4be32f0ad96f255e23a83396e2592b4f911f fix_headroom.patch"
+sha512sums="078017af7365426af820d4db5c6623e48d858a38941cc6e29ca97254b36832f6f6c8d76998952a231c4b826e8e01cf9841b051f158b30148597c06d47b83a6cb bfs-1.2.3.tar.gz"
diff --git a/testing/bfs/fix_headroom.patch b/testing/bfs/fix_headroom.patch
deleted file mode 100644
index 8d3538403b..0000000000
--- a/testing/bfs/fix_headroom.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/exec.c 2018-07-10 13:36:22.698784874 +0000
-+++ b/exec.c 2018-07-10 13:37:32.296154568 +0000
-@@ -92,11 +92,16 @@
- // Assume arguments are counted with the granularity of a single page,
- // and allow two pages of headroom to account for rounding as well as
- // any other data we may not be counting
-+ // so allow a one page cushion to account for rounding up
- long page_size = sysconf(_SC_PAGESIZE);
- if (page_size < 4096) {
- page_size = 4096;
- }
-- arg_max -= 2*page_size;
-+ arg_max -= page_size;
-+ bfs_exec_debug(execbuf, "ARG_MAX: %ld remaining after page cushion\n", arg_max);
-+
-+ // POSIX recommends an additional 2048 bytes of headroom
-+ arg_max -= 2048;
- bfs_exec_debug(execbuf, "ARG_MAX: %ld remaining after headroom\n", arg_max);
-
- if (arg_max < 0) {