aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bluez-alsa
diff options
context:
space:
mode:
authorBradley Saulteaux <-@bradso.to>2019-07-08 00:29:39 -0600
committerLeo <thinkabit.ukim@gmail.com>2019-07-09 00:20:58 -0300
commite44d1211f3b3dd6e7faddaeca76752b1fb337d97 (patch)
tree9213fd2471ea7ec6fd6c20139d284b3cf9533885 /testing/bluez-alsa
parent0426c18dba45da53c234878e7591ca2e8e578f91 (diff)
downloadaports-e44d1211f3b3dd6e7faddaeca76752b1fb337d97.tar.bz2
aports-e44d1211f3b3dd6e7faddaeca76752b1fb337d97.tar.xz
testing/bluez-alsa: new aport
https://github.com/Arkq/bluez-alsa Bluetooth Audio ALSA Backend
Diffstat (limited to 'testing/bluez-alsa')
-rw-r--r--testing/bluez-alsa/APKBUILD33
-rwxr-xr-xtesting/bluez-alsa/bluealsa.initd7
2 files changed, 40 insertions, 0 deletions
diff --git a/testing/bluez-alsa/APKBUILD b/testing/bluez-alsa/APKBUILD
new file mode 100644
index 0000000000..8498afd44e
--- /dev/null
+++ b/testing/bluez-alsa/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Bradley Saulteaux <-@bradso.to>
+pkgname=bluez-alsa
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="Bluetooth Audio ALSA Backend"
+url="https://github.com/Arkq/bluez-alsa"
+arch="all"
+license="MIT"
+depends="bluez"
+subpackages="$pkgname-openrc"
+makedepends="automake autoconf libtool alsa-lib-dev bluez-dev glib-dev sbc-dev"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/Arkq/$pkgname/archive/v$pkgver.tar.gz
+ bluealsa.initd"
+
+prepare() {
+ default_prepare
+ autoreconf --install
+ mkdir build
+}
+
+build() {
+ cd build
+ ../configure --enable-ofono --disable-static
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+ install -Dm755 ../../bluealsa.initd "$pkgdir"/etc/init.d/bluealsa
+}
+sha512sums="fa4ad21c7b9ac200cdc7628bf0276bbb0beac94066a6c5e69c47a5286f6e13a7dc61caab23acbb14a37c2b97894c425052a09adb8f967038f6fd99557208629f bluez-alsa-1.4.0.tar.gz
+7952c75a47ef8bbbd9ea7c8f16e62ff6355db4011a4c3a7c9d084c740cebde945bb443a987169a8e314d422958288fd02704a25d28c9770fcb8a2c050530ab26 bluealsa.initd"
diff --git a/testing/bluez-alsa/bluealsa.initd b/testing/bluez-alsa/bluealsa.initd
new file mode 100755
index 0000000000..01b6d82688
--- /dev/null
+++ b/testing/bluez-alsa/bluealsa.initd
@@ -0,0 +1,7 @@
+#!/sbin/openrc-run
+depend() {
+ need bluetooth
+}
+command="/usr/bin/$RC_SVCNAME"
+command_background="yes"
+pidfile="/run/$RC_SVCNAME.pid"