aboutsummaryrefslogtreecommitdiffstats
path: root/testing/bogofilter
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-05-05 15:59:31 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-05-05 15:59:40 +0000
commit88cbdc047dbf752ed769377ab35d2fb69710e615 (patch)
tree9cd1b5689994dcf54f58a090e62f3601023e2639 /testing/bogofilter
parent31f8bc2b27c369bbddd5ca97447d8a0df1bf6037 (diff)
downloadaports-88cbdc047dbf752ed769377ab35d2fb69710e615.tar.bz2
aports-88cbdc047dbf752ed769377ab35d2fb69710e615.tar.xz
testing/bogofilter: New aport. Re-added commit a30ee5b195f1ebfa77f18479954b0187f3456557 with the right path
Diffstat (limited to 'testing/bogofilter')
-rw-r--r--testing/bogofilter/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/bogofilter/APKBUILD b/testing/bogofilter/APKBUILD
new file mode 100644
index 0000000000..508c165196
--- /dev/null
+++ b/testing/bogofilter/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=bogofilter
+pkgver=1.2.4
+pkgrel=0
+pkgdesc="A Bayesian mail filter that classifies mail by statistical analysis of the message's header and content."
+url="http://bogofilter.sourceforge.net/"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="sqlite-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/bogofilter/bogofilter-stable/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.bz2"
+
+builddir=${srcdir}/${pkgname}-${pkgver}
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --with-included-gsl \
+ --with-database=sqlite3 || return 1
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR=${pkgdir} install
+}
+
+md5sums="d0a5eebb3274b23ceabe766a6443a1c5 bogofilter-1.2.4.tar.bz2"
+sha256sums="e10287a58d135feaea26880ce7d4b9fa2841fb114a2154bf7da8da98aab0a6b4 bogofilter-1.2.4.tar.bz2"
+sha512sums="e8c0b6bcc14f12fbbb2752e697a6d9065e17abfca3f70045ce9fe668d01c1cfad4adaa35c81546ecdd3639b0c28f3f4776bb5ed4699f21e9e2a5b19ca33479db bogofilter-1.2.4.tar.bz2"