aboutsummaryrefslogtreecommitdiffstats
path: root/testing/catimg
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2020-04-08 22:56:24 -0400
committerLeo <thinkabit.ukim@gmail.com>2020-04-10 02:30:24 +0000
commitf450b6aa8234a6d250c49dc6121a9aeeab61073b (patch)
treed91ad0fd50feace65ddc0af4e57de355e4b673bf /testing/catimg
parent71422a70753279ebc94f0cb05a0685720020caaa (diff)
downloadaports-f450b6aa8234a6d250c49dc6121a9aeeab61073b.tar.bz2
aports-f450b6aa8234a6d250c49dc6121a9aeeab61073b.tar.xz
testing/catimg: new aport
https://github.com/posva/catimg terminal image renderer testing/
Diffstat (limited to 'testing/catimg')
-rw-r--r--testing/catimg/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/catimg/APKBUILD b/testing/catimg/APKBUILD
new file mode 100644
index 0000000000..4521692704
--- /dev/null
+++ b/testing/catimg/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname=catimg
+pkgver=2.6.0
+pkgrel=0
+pkgdesc="terminal image renderer"
+url="https://github.com/posva/catimg"
+arch="all"
+license="MIT"
+makedepends="cmake"
+options="!check" # no tests
+subpackages="$pkgname-doc"
+source="catimg-$pkgver.tar.gz::https://github.com/posva/catimg/archive/$pkgver.tar.gz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ $CMAKE_CROSSOPTS .
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="a3c0ed92a797dc6e213e202cf36d4da32f4baba0ba4dc60875f4df152e3df10ec2276723e10826ce13ac1ddb4f32f75e0d6851767003032ecaa73fe0851e6559 catimg-2.6.0.tar.gz"