aboutsummaryrefslogtreecommitdiffstats
path: root/testing/clipman
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2020-02-02 17:35:36 -0500
committerLeo <thinkabit.ukim@gmail.com>2020-02-03 02:14:22 +0100
commit0f700bc9a5a0d38b4eaa23f0cce48592b7a3d6e5 (patch)
tree9a04e2bd7b1bebfc1f078e58e3681c3f90fea55b /testing/clipman
parent46903ed2aecd6fda6af82267eac1fcb4c188e72d (diff)
downloadaports-0f700bc9a5a0d38b4eaa23f0cce48592b7a3d6e5.tar.bz2
aports-0f700bc9a5a0d38b4eaa23f0cce48592b7a3d6e5.tar.xz
testing/clipman: new aport
https://github.com/yory8/clipman A simple clipboard manager for Wayland testing/
Diffstat (limited to 'testing/clipman')
-rw-r--r--testing/clipman/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/clipman/APKBUILD b/testing/clipman/APKBUILD
new file mode 100644
index 0000000000..e2f29a0cd2
--- /dev/null
+++ b/testing/clipman/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname="clipman"
+pkgver="1.2.0"
+pkgrel=0
+pkgdesc="A simple clipboard manager for Wayland"
+url="https://github.com/yory8/clipman"
+arch="all"
+license="GPL-3.0-only"
+depends="wl-clipboard"
+makedepends="go"
+options="!check" # no tests
+source="$pkgname-$pkgver.tar.gz::https://github.com/yory8/clipman/archive/v$pkgver.tar.gz"
+
+build() {
+ go build -o $pkgname
+}
+
+package() {
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+}
+sha512sums="677652bc21b8b6d800c615d3ffc70fa934b8d934d430eec5f0baf262822092a138e4514c01415eae4584dbbc30c33d147a54f5ba06b1e2f468ae984769ddcfd1 clipman-1.2.0.tar.gz"