aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cloudi
diff options
context:
space:
mode:
authorMichael Truog <mjtruog@gmail.com>2017-08-02 18:45:40 -0700
committerWilliam Pitcock <nenolod@dereferenced.org>2017-08-03 20:36:58 +0000
commite259406f44e50c905d90f1a6576a72099a90862e (patch)
treeaa38340244a87f9f7523077542bd24b0aa637b1f /testing/cloudi
parent457092b48dad405167de988727026430619e6299 (diff)
downloadaports-e259406f44e50c905d90f1a6576a72099a90862e.tar.bz2
aports-e259406f44e50c905d90f1a6576a72099a90862e.tar.xz
testing/cloudi: configuration fixes
* cloudi.initd required the HOME environment variable due to erlang's erlexec * 0010-Set-configured-log-path.patch was necessary to fix a path in /etc/cloudi/cloudi.conf * Make the erlang package a runtime dependency
Diffstat (limited to 'testing/cloudi')
-rw-r--r--testing/cloudi/0010-Set-configured-log-path.patch11
-rw-r--r--testing/cloudi/APKBUILD10
-rw-r--r--testing/cloudi/cloudi.initd8
3 files changed, 21 insertions, 8 deletions
diff --git a/testing/cloudi/0010-Set-configured-log-path.patch b/testing/cloudi/0010-Set-configured-log-path.patch
new file mode 100644
index 0000000000..bd0843d463
--- /dev/null
+++ b/testing/cloudi/0010-Set-configured-log-path.patch
@@ -0,0 +1,11 @@
+--- src/cloudi_minimal.conf.in
++++ src/cloudi_minimal.conf.in
+@@ -14,7 +14,7 @@
+ [{prefix, "/cloudi/log/"},
+ {module, cloudi_service_filesystem},
+ {args,
+- [{directory, "@prefix@/var/log/cloudi"},
++ [{directory, "/var/log/cloudi"},
+ {read, [{"/cloudi/log/cloudi.log", -16384}]},
+ {refresh, 10}]},
+ {dest_refresh, none}],
diff --git a/testing/cloudi/APKBUILD b/testing/cloudi/APKBUILD
index 0866a684d7..0d2175fbc4 100644
--- a/testing/cloudi/APKBUILD
+++ b/testing/cloudi/APKBUILD
@@ -30,19 +30,19 @@
pkgname=cloudi
pkgver=1.7.2_rc1
_srcver=70addfda7133ac209157d48e38be70be7597ce8a
-pkgrel=1
+pkgrel=2
pkgdesc="Cloud computing framework for efficient, scalable, and stable soft-realtime event processing."
url="http://cloudi.org/"
license="MIT"
arch="all"
-depends="g++"
+depends="erlang
+ g++"
makedepends="autoconf
automake
binutils-dev
boost-dev
boost-system
boost-thread
- erlang
erlang-asn1
erlang-common-test
erlang-crypto
@@ -74,6 +74,7 @@ install=""
subpackages=""
source="https://github.com/$pkgname/$pkgname/archive/$_srcver.tar.gz
0005-Disable-tests-for-aports-buildservers.patch
+ 0010-Set-configured-log-path.patch
$pkgname.initd"
builddir="$srcdir/CloudI-$_srcver/src"
@@ -115,4 +116,5 @@ package() {
sha512sums="c47d3016002c5cf76782eb45a8c9da8aafa27d2046c82d6339dd59b88fb84e7c17f7df67071d9c3ca4fc8e87cd45980494664cd4ba5fb8900a67e47e909a0e7c 70addfda7133ac209157d48e38be70be7597ce8a.tar.gz
cf380a2585e6116b3a0bc21b9846d91b96adcb754fa0805b571e99bbd9f696aa636d0bdeb6d85d05e34b65f8880afb01a02abb09e6797af1d4586664427add75 0005-Disable-tests-for-aports-buildservers.patch
-08e930424d4b7f4bbb7888fc9c16f6007a215886ebd0bdf4a296d4870d8d4e48bcc9df11ab79362aae238c3ae30a05dc47d9fbbc54fe07306dd06e8336576ad8 cloudi.initd"
+cea17814085d40cc56ce21465bff1f8dd9f37f93e237e63b333d9f5d7093d6880b3204879eb8e2175e056d73928cff3d42efab897713d04f8cac87e7f07f970e 0010-Set-configured-log-path.patch
+053f860f656617012208a0e1909e43b2f8979d381a90d3fa5a745a9cf5021fe54556a641fef2badaa9955f2394d00e32183389cb9b501169dcbf8cbe4fbb0329 cloudi.initd"
diff --git a/testing/cloudi/cloudi.initd b/testing/cloudi/cloudi.initd
index 8fc9ad1377..77fd99b513 100644
--- a/testing/cloudi/cloudi.initd
+++ b/testing/cloudi/cloudi.initd
@@ -15,16 +15,16 @@ depend() {
after firewall
}
start() {
- $command start
+ HOME="/" $command start
}
stop() {
- $command stop
+ HOME="/" $command stop
}
restart() {
- $command restart
+ HOME="/" $command restart
}
status() {
- $command test
+ HOME="/" $command test
if [ $? -eq 0 ]; then
einfo "status: started"
return 0