aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cntlm
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-01-10 13:39:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-01-10 13:39:25 +0000
commit954d3f32d8f7b461be438249ea21112c315fe709 (patch)
tree0795260fa25f4c58c6a7417775e234eca828d8bd /testing/cntlm
parentf132f84d1989b4b6e29a6c51c2a71bc4ef02acac (diff)
downloadaports-954d3f32d8f7b461be438249ea21112c315fe709.tar.bz2
aports-954d3f32d8f7b461be438249ea21112c315fe709.tar.xz
testing/cntlm: modernize pidfile location, split -openrc
Diffstat (limited to 'testing/cntlm')
-rw-r--r--testing/cntlm/APKBUILD10
-rw-r--r--testing/cntlm/cntlm.initd4
2 files changed, 5 insertions, 9 deletions
diff --git a/testing/cntlm/APKBUILD b/testing/cntlm/APKBUILD
index 6fbcc13d8b..c4457c564d 100644
--- a/testing/cntlm/APKBUILD
+++ b/testing/cntlm/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cntlm
pkgver=0.92.3
-pkgrel=2
+pkgrel=3
pkgdesc="NTLM Session Response / NTLMv2 authenticating HTTP proxy"
url="http://cntlm.sourceforge.net/"
arch="all"
@@ -9,7 +9,7 @@ license="GPL-2.0-or-later"
depends=""
makedepends=""
install=""
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-openrc"
source="https://downloads.sourceforge.net/project/cntlm/cntlm/cntlm%20$pkgver/cntlm-$pkgver.tar.gz
cntlm.initd
"
@@ -30,9 +30,5 @@ package() {
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
}
-md5sums="0d7fcfbfbef0546306b896be246caa88 cntlm-0.92.3.tar.gz
-9837b30f345c621b8d60db59a772a65c cntlm.initd"
-sha256sums="9c3ad10924d43f7248df9ecd33cbc033afbd7ea8d9545de0d68a2782fed76298 cntlm-0.92.3.tar.gz
-082cd3fce99222166261485830b2a565008a3e006b2ba82a4504422a047d60e2 cntlm.initd"
sha512sums="64f97524f1c807dd3bad3f6c1cffb9d3315c720b086336b7379c8c6380c7c483a9c810b40e7e5ea463387476cd718a8e5fcbc1c7103d7128dfc72a8607e6fd39 cntlm-0.92.3.tar.gz
-d77aaad9cf95c5631032d023fb05964fbee2febe6ca5a1f93c95936d1fc9f53321d62fa69ef8bab8045d271109b0bfc0896628859c7a6bf9e76cad3efa5d4fee cntlm.initd"
+64df05631a92a92a90cbd5170d1c5215972f0e52c1b7522fc20795de7062e403159ad95c7a50d40bbc721a596dd5e707f12384613defc683c66c82f97dabe271 cntlm.initd"
diff --git a/testing/cntlm/cntlm.initd b/testing/cntlm/cntlm.initd
index 449d1f2361..86490eaee0 100644
--- a/testing/cntlm/cntlm.initd
+++ b/testing/cntlm/cntlm.initd
@@ -12,10 +12,10 @@ checkconfig() {
CNTLM_INSTANCE=${SVCNAME#*.}
if [ -n "${CNTLM_INSTANCE}" -a "${SVCNAME}" != "cntlm" ]; then
CNTLM_CONF="/etc/cntlm.d/${CNTLM_INSTANCE}.conf"
- CNTLM_PID="/var/run/cntlm.${CNTLM_INSTANCE}.pid"
+ CNTLM_PID="/run/cntlm.${CNTLM_INSTANCE}.pid"
else
CNTLM_CONF="/etc/cntlm.conf"
- CNTLM_PID="/var/run/cntlm.pid"
+ CNTLM_PID="/run/cntlm.pid"
fi
if [ ! -e ${CNTLM_CONF} ]; then
eerror "You will need an ${CNTLM_CONF} first"