aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cockroach
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2019-10-04 19:18:05 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2019-10-04 20:14:48 +0200
commitbda9fed96df73fbcb57f586aa89d859541653e43 (patch)
treee99ef9ce5f4982525c6d99f325593ff2c617cb20 /testing/cockroach
parent9eea81c09efa8da4fb4cb7f59509d3575a7a88f6 (diff)
downloadaports-bda9fed96df73fbcb57f586aa89d859541653e43.tar.bz2
aports-bda9fed96df73fbcb57f586aa89d859541653e43.tar.xz
testing/cockroach: disable go module support
Diffstat (limited to 'testing/cockroach')
-rw-r--r--testing/cockroach/APKBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/testing/cockroach/APKBUILD b/testing/cockroach/APKBUILD
index 622707da65..43bb422e3e 100644
--- a/testing/cockroach/APKBUILD
+++ b/testing/cockroach/APKBUILD
@@ -20,6 +20,9 @@ source="${pkgname}-v${pkgver}.tar.gz::https://binaries.cockroachdb.com/${pkgname
builddir=${srcdir}/${pkgname}-v${pkgver}
+# Fails with a permission denied error on some builders without this.
+export GO111MODULE=off
+
build() {
local flags="-D_BSD_SOURCE -Wno-format"
make CXXFLAGS="$flags -Wno-deprecated-copy -Wno-redundant-move -Wno-pessimizing-move -Wno-array-bounds" \