aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cockroach
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2019-10-04 18:18:23 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2019-10-04 20:14:48 +0200
commitee96166af3af712e65391a61c2fcf648441b7709 (patch)
tree1d5af8cb1599f6db07500d349a615bee9af4e274 /testing/cockroach
parente1032317ff91d818c39081c3e71c9a9cb8b42865 (diff)
downloadaports-ee96166af3af712e65391a61c2fcf648441b7709.tar.bz2
aports-ee96166af3af712e65391a61c2fcf648441b7709.tar.xz
testing/cockroach: fix build with gcc9
By disabling various warnings.
Diffstat (limited to 'testing/cockroach')
-rw-r--r--testing/cockroach/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/testing/cockroach/APKBUILD b/testing/cockroach/APKBUILD
index 701e8f5be6..f50fdc624c 100644
--- a/testing/cockroach/APKBUILD
+++ b/testing/cockroach/APKBUILD
@@ -21,7 +21,10 @@ source="${pkgname}-v${pkgver}.tar.gz::https://binaries.cockroachdb.com/${pkgname
builddir=${srcdir}/${pkgname}-v${pkgver}
build() {
- make CXXFLAGS="-D_BSD_SOURCE" CFLAGS="-D_BSD_SOURCE" TAGS="stdmalloc" BUILDTYPE="release" buildoss
+ local flags="-D_BSD_SOURCE -Wno-format"
+ make CXXFLAGS="$flags -Wno-deprecated-copy -Wno-redundant-move -Wno-pessimizing-move -Wno-array-bounds" \
+ CFLAGS="$flags" \
+ TAGS="stdmalloc" BUILDTYPE="release" buildoss
}
package() {