aboutsummaryrefslogtreecommitdiffstats
path: root/testing/colormake
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2017-05-25 22:34:05 +0200
committerShiz <hi@shiz.me>2017-06-02 11:28:17 +0200
commiteac3cd24245d20afd46fac0f1bdc39c1e9ba2e10 (patch)
treefe1f567803df7070eb539cdbffaa028b74707b32 /testing/colormake
parent362127bbcc098d59cb9c75c257d708ce716c7f5c (diff)
downloadaports-eac3cd24245d20afd46fac0f1bdc39c1e9ba2e10.tar.bz2
aports-eac3cd24245d20afd46fac0f1bdc39c1e9ba2e10.tar.xz
testing/colormake: new aport
Diffstat (limited to 'testing/colormake')
-rw-r--r--testing/colormake/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/colormake/APKBUILD b/testing/colormake/APKBUILD
new file mode 100644
index 0000000000..751120aac7
--- /dev/null
+++ b/testing/colormake/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
+# Maintainer: Henrik Riomar <henrik.riomar@gmail.com>
+pkgname=colormake
+pkgver=0.9.20140503
+pkgrel=0
+pkgdesc="A simple wrapper around make to colorize the output"
+url="http://bre.klaki.net/programs/colormake"
+arch="noarch"
+license="GPL2+"
+depends="perl"
+options="!check"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/pagekite/Colormake/archive/$pkgver.tar.gz"
+builddir="$srcdir/Colormake-$pkgver"
+
+build() {
+ cd "$builddir"
+ sed -i 's|colormake.pl|/usr/share/colormake/&|' colormake
+}
+
+package() {
+ cd "$builddir"
+ install -Dm0755 colormake "$pkgdir"/usr/bin/colormake
+ install -Dm0755 colormake.pl "$pkgdir"/usr/share/colormake/colormake.pl
+ install -Dm0644 colormake.1 "$pkgdir"/usr/share/man/man1/colormake.1
+}
+
+sha512sums="91ca0a22b1ab34c729228f14eab6232df11576c3ac66398e2a6cbbe36a7a1ab5434897f44b411deb7e3c703aac2c9a13e0d0d9906b86339252832edc7b44f271 colormake-0.9.20140503.tar.gz"