aboutsummaryrefslogtreecommitdiffstats
path: root/testing/confd
diff options
context:
space:
mode:
authortang0th <tang0th@gmx.com>2016-03-05 23:07:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-06-21 21:46:36 +0000
commitaf406dac1278ba29b7f83d75de264ed2740c47b2 (patch)
tree99f8c5bd803055ffeae5ee6e36f0d99766bc9ab0 /testing/confd
parentec6a251a08e58f37e9b4d46619a75095337cdb18 (diff)
downloadaports-af406dac1278ba29b7f83d75de264ed2740c47b2.tar.bz2
aports-af406dac1278ba29b7f83d75de264ed2740c47b2.tar.xz
New aport: confd
Diffstat (limited to 'testing/confd')
-rw-r--r--testing/confd/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/confd/APKBUILD b/testing/confd/APKBUILD
new file mode 100644
index 0000000000..18ab6deb8d
--- /dev/null
+++ b/testing/confd/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: tang0th <tang0th@gmx.com>
+# Maintainer:
+pkgname=confd
+pkgver=0.11.0_git20160305
+_pkgcommit=d4231233d713c363f9ca7bb60dcd2c2b55d1d31b
+pkgrel=0
+pkgdesc="Manage local application configuration files using templates and data from etcd or consul"
+url="http://confd.io"
+arch="all"
+license="BSD"
+depends="musl"
+depends_dev=""
+makedepends="$depends_dev go"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/kelseyhightower/$pkgname/archive/$_pkgcommit.tar.gz"
+
+_builddir="$srcdir/$pkgname-$_pkgcommit"
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$srcdir"
+ export GOPATH="$PWD"
+ export GO15VENDOREXPERIMENT=1
+
+ mkdir -p src/github.com/kelseyhightower/
+ cp -r "$_builddir" src/github.com/kelseyhightower/confd
+
+ go install github.com/kelseyhightower/confd
+}
+
+package() {
+ cd "$srcdir"
+
+ install -Dm755 bin/confd $pkgdir/usr/bin/confd || return 1
+}
+
+md5sums="cd983707d8c27fed52d0f37c787784f1 confd-0.11.0_git20160305.tar.gz"
+sha256sums="8474baf1ae52d39273332096c67b016c7022f2ea2edc0d6b6a9406fcd109ab2e confd-0.11.0_git20160305.tar.gz"
+sha512sums="7aab758d9ad756a7a325eee405f5875e6628b333e8d9ac6521811747e763d3ad22b536a8160338ad0f4570ab934114eb5e0632d002fcf6b71605c87e3b749ea9 confd-0.11.0_git20160305.tar.gz"