aboutsummaryrefslogtreecommitdiffstats
path: root/testing/conmon/APKBUILD
diff options
context:
space:
mode:
authorKohei Nishimura <kohnish@gmx.com>2019-12-26 21:16:31 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-27 02:35:04 +0100
commitacfc4f552344d874342e9aa8792458b5051d4939 (patch)
treec2162288a09f5906db514d548093e983882f4339 /testing/conmon/APKBUILD
parentfe6c7cdb7ba75d797848ee44db49099237ebd9a0 (diff)
downloadaports-acfc4f552344d874342e9aa8792458b5051d4939.tar.bz2
aports-acfc4f552344d874342e9aa8792458b5051d4939.tar.xz
testing/conmon: new aports
An OCI container runtime monitor https://github.com/containers/conmon
Diffstat (limited to 'testing/conmon/APKBUILD')
-rw-r--r--testing/conmon/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/conmon/APKBUILD b/testing/conmon/APKBUILD
new file mode 100644
index 0000000000..32fa2a8785
--- /dev/null
+++ b/testing/conmon/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor:
+# Maintainer:
+pkgname=conmon
+pkgver=2.0.7
+pkgrel=0
+pkgdesc="An OCI container runtime monitor"
+url="https://github.com/containers/conmon"
+arch="all"
+license="Apache-2.0"
+makedepends="glib-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/containers/conmon/archive/v$pkgver.tar.gz"
+
+build() {
+ make
+}
+
+check() {
+ ./bin/conmon --version
+}
+
+package() {
+ make install PREFIX=/usr DESTDIR="$pkgdir"
+}
+
+
+sha512sums="700297016bb3471a7dc5ed243df69bf21d459d612ee23ba325ff0c8ff8842f77d2601e155326c80ebe86cc8e6fb0a45603fac401bfcdbea184d39358cedeafac conmon-2.0.7.tar.gz"