aboutsummaryrefslogtreecommitdiffstats
path: root/testing/consul/consul.pre-install
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-04-28 13:27:48 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2015-04-28 13:29:23 +0200
commitc05fd0282aa9d14f15690308761caf93805285f7 (patch)
tree8856d40dc52a8b3b1437584ad5fdc14c72e79996 /testing/consul/consul.pre-install
parent15a3137ad2d71eea7ea9ea8d6a912545a36947b2 (diff)
downloadaports-c05fd0282aa9d14f15690308761caf93805285f7.tar.bz2
aports-c05fd0282aa9d14f15690308761caf93805285f7.tar.xz
testing/consul: new aport
APKBUILD provided by Olivier Mauras <olivier@mauras.ch>
Diffstat (limited to 'testing/consul/consul.pre-install')
-rw-r--r--testing/consul/consul.pre-install7
1 files changed, 7 insertions, 0 deletions
diff --git a/testing/consul/consul.pre-install b/testing/consul/consul.pre-install
new file mode 100644
index 0000000000..aef4230557
--- /dev/null
+++ b/testing/consul/consul.pre-install
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+# Create consul group and user
+addgroup -S consul 2> /dev/null
+adduser -h /var/consul -s /sbin/nologin -G consul -S -D consul 2> /dev/null
+exit 0
+