aboutsummaryrefslogtreecommitdiffstats
path: root/testing/copyq
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-12-26 19:40:25 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-12-26 19:40:30 +0000
commit01e086ca127be23bcca5b6b668527a32e334281d (patch)
tree3a02f169d3b37600069fb5151f9e55c864445d0d /testing/copyq
parent60aa3d265e7bf4975810ba438754fcb33ed77f97 (diff)
downloadaports-01e086ca127be23bcca5b6b668527a32e334281d.tar.bz2
aports-01e086ca127be23bcca5b6b668527a32e334281d.tar.xz
testing/copyq: new aport
Diffstat (limited to 'testing/copyq')
-rw-r--r--testing/copyq/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/copyq/APKBUILD b/testing/copyq/APKBUILD
new file mode 100644
index 0000000000..9bc2c9d095
--- /dev/null
+++ b/testing/copyq/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=copyq
+_pkgname=CopyQ
+pkgver=3.1.2
+pkgrel=0
+pkgdesc="Clipboard manager with searchable and editable history"
+url="https://github.com/hluk/CopyQ"
+arch="all"
+license="GPL3"
+makedepends="cmake qt5-qtscript-dev qt5-qttools-dev qt5-qtsvg-dev
+ libxfixes-dev libxtst-dev"
+options="!check" #upstream does not provide check
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hluk/${_pkgname}/archive/v${pkgver}.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ mkdir "$builddir"/build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_QT5=TRUE \
+ ..
+ make
+}
+
+package() {
+ cd "$builddir"/build
+ make DESTDIR="${pkgdir}" install
+}
+
+sha512sums="3d1e37e5194dfff4269b1124f734308e42cb2daa0930dcc0a9b1261ddb40451187c358088a51d76f41ade6fb943b3617128a82f0fd4b06c6c097069616811933 copyq-3.1.2.tar.gz"