aboutsummaryrefslogtreecommitdiffstats
path: root/testing/coreshot
diff options
context:
space:
mode:
authorrahmanshaber <rahmanshaber@yahoo.com>2019-07-29 12:07:47 +0800
committerLeo <thinkabit.ukim@gmail.com>2019-07-29 03:58:52 -0300
commit06cc1dac8c0f9330fd46b493f13fdfb3481a8cf7 (patch)
tree4e08e1d70bd2c89de6e30860e0d2da504c5d7f97 /testing/coreshot
parent5e62b02469fdc6d9374fe371528a22ba93946aef (diff)
downloadaports-06cc1dac8c0f9330fd46b493f13fdfb3481a8cf7.tar.bz2
aports-06cc1dac8c0f9330fd46b493f13fdfb3481a8cf7.tar.xz
testing/coreshot: new aport
Diffstat (limited to 'testing/coreshot')
-rw-r--r--testing/coreshot/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/coreshot/APKBUILD b/testing/coreshot/APKBUILD
new file mode 100644
index 0000000000..1152752a3a
--- /dev/null
+++ b/testing/coreshot/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
+# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
+pkgname=coreshot
+pkgver=2.6.0
+pkgrel=0
+pkgdesc="A screen capture utility from the CoreApps family."
+arch="all"
+url="https://gitlab.com/cubocore"
+license="GPL-2.0-only"
+depends="qt5-qtsvg"
+makedepends="qt5-qtbase-dev libcprime-dev qt5-qtx11extras-dev"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-v$pkgver"
+options="!check"
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+}
+sha512sums="cde3fa7a6387395b13d5fd68f4e5351843f56dd1c3ae6c7fbef75c451839bf4cdb06d4853f70ba4ae7cc27b83c179fb37ab61643983ae6514c6adb802128254f coreshot-2.6.0.tar.gz"