aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cowpatty
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-12-11 05:59:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-16 13:49:27 +0000
commit70ab9cfdc15de810fb71363b0bff829372500d80 (patch)
treef587e657936c828df111bc32869718d0c3dece67 /testing/cowpatty
parent23059b966e4169fc67b56e093630461fc93c1f35 (diff)
downloadaports-70ab9cfdc15de810fb71363b0bff829372500d80.tar.bz2
aports-70ab9cfdc15de810fb71363b0bff829372500d80.tar.xz
testing/cowpatty: Inital APKBUILD
Package description: Implementation of an offline dictionary attack against WPA/WPA2 networks using PSK-based authentication (e.g. WPA-Personal). Many enterprise networks deploy PSK-based authentication mechanisms for WPA/WPA2 since it is much easier than establishing the necessary RADIUS, supplicant and certificate authority architecture needed for WPA-Enterprise authentication. Cowpatty can implement an accelerated attack if a precomputed PMK file is available for the SSID that is being assessed. Website: http://www.willhackforsushi.com/Cowpatty.html
Diffstat (limited to 'testing/cowpatty')
-rw-r--r--testing/cowpatty/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/cowpatty/APKBUILD b/testing/cowpatty/APKBUILD
new file mode 100644
index 0000000000..198533fe9e
--- /dev/null
+++ b/testing/cowpatty/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=cowpatty
+pkgver=4.3
+pkgrel=0
+pkgdesc="Attacking WPA/WPA2-PSK exchanges"
+url="http://www.willhackforsushi.com/Cowpatty.html"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="libpcap-dev openssl-dev"
+install=""
+subpackages=""
+source="http://www.willhackforsushi.com/code/$pkgname/$pkgver/$pkgname-$pkgver.tgz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -m755 -D "$_builddir"/$pkgname \
+ "$pkgdir"/usr/bin/$pkgname || return 1
+ install -m755 -D "$_builddir"/genpmk \
+ "$pkgdir"/usr/bin/genpmk || return 1
+}
+
+md5sums="deccac0763a05ef7014107d347bf9190 cowpatty-4.3.tgz"