aboutsummaryrefslogtreecommitdiffstats
path: root/testing/cpiped
diff options
context:
space:
mode:
authorMarvin Steadfast <marvin@xsteadfastx.org>2017-08-10 13:04:14 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-08-25 23:18:21 +0000
commitc387838a5c5c593075fe3e16850e2f5aacb84875 (patch)
treee9523a9b506c996575ae89125fed10a8959b4190 /testing/cpiped
parent656edb0a9fee0756cb5c0c41134577abdec4d2d1 (diff)
downloadaports-c387838a5c5c593075fe3e16850e2f5aacb84875.tar.bz2
aports-c387838a5c5c593075fe3e16850e2f5aacb84875.tar.xz
testing/cpiped: new aport
Diffstat (limited to 'testing/cpiped')
-rw-r--r--testing/cpiped/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/cpiped/APKBUILD b/testing/cpiped/APKBUILD
new file mode 100644
index 0000000000..b1f7e4f0d0
--- /dev/null
+++ b/testing/cpiped/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Marvin Steadfast <marvin@xsteadfastx.org>
+pkgname=cpiped
+_commit_sha=3abe3cc6e09d65bf45a28cb8f9f8695acce1deb9
+pkgver=0_git20170323
+pkgrel=0
+pkgdesc="Captures an audio stream and outputs it to a pipe"
+url="https://github.com/b-fitzpatrick/cpiped"
+arch="all"
+license="GPL3"
+options="!check"
+depends=""
+makedepends="alsa-lib-dev"
+install=
+subpackages=
+source="cpiped-$pkgver.tar.gz::https://github.com/b-fitzpatrick/cpiped/archive/$_commit_sha.tar.gz"
+builddir="$srcdir/cpiped-$_commit_sha"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 cpiped "$pkgdir"/usr/bin/cpiped
+}
+
+sha512sums="b1fa3b79e5929f21a323a410e475f41af719c0d94e89a3baa1a9b83d594ca56b8dd586371ced4cec7a2f9c2fcc7508cacf2e2c1e0eda54e5d90ecc13f2c2c337 cpiped-0_git20170323.tar.gz"